WordPress.org

Forums

Jetpack by WordPress.com
Potential Conflict with Photon and Twenty Ten Featured Image Headers (11 posts)

  1. MRWweb
    Member
    Posted 2 years ago #

    I'm running a custom child theme of Twenty Ten that utilizes the custom header options in Twenty Ten. However, when I turn on Photon, the custom headers disappear and revert to the default header image.

    I see that Twenty Ten appears to be using the deprecated method of setting up custom headers, so that might potentially be the issue, but since these are both "official" themes/plugins, I wanted to see if anyone has seen this issue before.

    Site is: http://beta.solar-circle.org

    http://wordpress.org/extend/plugins/jetpack/

  2. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Hi! I had a look, and I don't see that Photon is turned on, and I see your featured image. Can you turn Photon on so I can see the problem? I'll check back here in a few minutes.

  3. MRWweb
    Member
    Posted 2 years ago #

    Sorry. I had deactivated it so the client could see it was working in theory :)

    It's turned back on and the problem's back. (I'm using WP Super Cache, but the problem occurs without it enabled too.)

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Sorry, I still don't see the problem with the images, they don't seem to be served by Photon again.

  5. MRWweb
    Member
    Posted 2 years ago #

    It looks like the header image isn't served by Photon (though notice that it's now the same on every page unlike before) but the sidebar image is and the Photon script is in the footer.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    I'm sorry, but I still don't see any images being served up by Photon. If they were, they'd look like this:

    http://i1.wp.com/beta.solar-circle.org/wp-content/uploads/2013/03/21/image.jpg

    Are you certain that Photon is currently turned on?

  7. MRWweb
    Member
    Posted 2 years ago #

    Yes, Photon is turned on and that's what I'm seeing. It does appear that the sidebar image is only being served from Photon sometimes. I can't see any logic to why.

  8. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Hi, I am unable to reproduce what you are seeing. The header image isn't served by Photon and won't be because of how Photon interacts with the theme header option, but activating Photon doesn't make my header disappear on my test site. Maybe having the defauly image show up as the header was caused by your caching plugin?

  9. MRWweb
    Member
    Posted 2 years ago #

    I'm pretty sure I ruled out caching by deactivating that plugin and all others except Photon.

    Right now Photon is completely disabled, but I'll see if I can recreate the issue on a new site.

  10. dbellamy
    Member
    Posted 2 years ago #

    I can confirm that this is still an issue with Photon in Jetpack 2.2.2 If Photon is activated it will not display feature pictures in my TwentyTen theme based web site. It worked fine in the past with previous versions of Jetpack, it no longer works now. When Photon is disabled feature pictures are correctly displayed on static pages as they were previously. April 13th, 2013

  11. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    dbellamy can you start a new thread, and include a link to your site? You can reference this thread in yours if you'd like. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic