• Resolved whizzbyte

    (@whizzbyte)


    Hello WooCommerce Support Team,

    I’ve been experiencing a potential compatibility issue with WooCommerce and PHP 8.1. The error I’m encountering is:

    “Deprecated: substr(): Passing null to parameter #1 ($string) of type string is deprecated in wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard-setup.php on line 96”

    The error specifically points to the WooCommerce plugin. Upon reviewing your official site, I found that WooCommerce is compatible with PHP 8.0, but compatibility with 8.1 remains uncertain.

    Could you please confirm if WooCommerce supports PHP 8.1 and provide guidance on how I can resolve this error?

    Thank you for your assistance.

    Best Regards,
    Roman Pota

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jon

    (@lanej0)

    Hi Roman,

    We’re working on compatibility with PHP 8.1. There are still a few rough edges, but the team and community are working to iron them out. Hopefully have full compatibility soon!

    Cheers,

    Jon

    Thread Starter whizzbyte

    (@whizzbyte)

    Thanks Jon. Highly appreciated!

    Hi @whizzbyte

    You are most welcome here! 🙂

    I will be marking this thread as resolved. Should you have further inquiries, kindly create a new topic here.

    Meanwhile, if you have a moment to spare, we would love it if you could share your thoughts with us by leaving a review or feedback. Your experience and feedback are important to help us improve and ensure we’re always providing the best possible support.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Potential Compatibility Issue with WooCommerce and PHP 8.1’ is closed to new replies.