Posts with lots of content won't publish (6 posts)

  1. manamana
    Posted 3 years ago #

    I'm relatively new to wordpress. Migrating from an ancient html site.

    I keep running into a problem where posts with lots (not really lots, but say 12 or so seems to be the limit) of images just simply won't publish or save drafts. I work for an hour, hit publish, and poof, page not found.

    I can make small posts (5-6 images) and things are fine. Everything else is great. The first time I noticed this I went back and did everything again, which then worked. Since then I've been ctr-c'ing all content before hitting publish. But I've tried to publish this one post 100+ times, and it never goes.

    The posts that have trouble can't autosave a draft either. It just sits there with the 'Saving Draft...' for hours and hours.

    I've tried switching to Twentytwelve and twentyeleven.
    I've tried disabling all plugins.
    logging out and logging back in.
    rebooting my computer.
    starting over from a new scratch post.

    I'm lost. Any ideas?

    [No bumping. If it's that urgent, consider hiring someone.]

  2. Tara
    Volunteer Moderator
    Posted 3 years ago #

    have you tried increasing memory available for php.

  3. manamana
    Posted 3 years ago #

    Tried that with no luck. I did

    define('WP_MEMORY_LIMIT', '96M');
    define('WP_MAX_MEMORY_LIMIT', '256M');

    I also checked with my host to see if they had any restrictions imposed. I was told 'php memory_limit is set to 64MB on server side and upload file limit to 20MB'

    I then described the problem I was having and they said they made some changes, which appears to have done something. Now, when I hit post, instead of erroring out with "page not found," It says 'post published' but the post doesn't actually publish, or save a draft. As before, all work is lost when attempting to publish or save. Small posts still work fine, and if there's any difference in the size of post that causes problems, it isn't great enough to be noticeable. I have asked what changes they made.

    So I'm thinking there's no way php_memory_limit is the issue? 15 images totaling 1.5 MB and a smattering of text is the absolute biggest thing I've tried to do in my experimenting.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Try checking your site's error logs for a more specific error message. Your host should be able to help you in accessing your site's error logs.

  5. manamana
    Posted 3 years ago #

    cpanel doesn't show anything in the error log, and someone at my host said they didn't see any either.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    It could be a server security configuration issue. See: http://wordpress.org/support/topic/cant-save-a-post-or-page-with-certain-text

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.