Support » Plugin: WordPress Popular Posts » Posts with Canonical Links not showing in popular posts feed

  • Resolved jennbryant

    (@jennbryant)


    This site features stories from other sites, but we create those stories as posts on our site then redirect them to the original site. We have canonical links on those posts. For some reason, Popular Posts only shows internal posts that do not point away from our site and does not consider any post that is directed to an external site. Is there any way to make it consider all posts?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    @sterndata please re-read the previous comments and tell me when exactly I asked the OP for credentials, because I don’t think I did.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    You asked for off-forum contact after the OP offered credentials. That’s not acceptable here. And @jennbryant you offered credentials, which also is not acceptable here. We have few absolute rules… that’s the big one.

    I have not flagged your accounts for moderation. We can just agree that this is stuff that should not be done in these forums.

    I see. So absolutely no offer of any kind of access. That is my mistake – I didn’t read the rules closely enough. In this case, I don’t know that the issue can be resolved.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    OP asked if there was a way to send the logs to me which is why I offered a link to my contact form. Instead of jumping to conclusions like that @sterndata it’d be nice if you asked first. Also, please refrain from removing/deleting comments from this conversation so lightly. It affects context when you do that and people won’t know what happened if they read this topic. Editing stuff out when possible would have been a better approach.

    @jennbryant since Steve edited the log I assume all of the messages where the two he left in there repeated a few times. If so, nothing in there indicates an issue related to the plugin. However, if there were more (different) messages in your log then please follow Steve’s suggestion and post your entire log on https://pastebing.org so I can have a look.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    If you have an issue with how things are moderated, please visit the forums channel on slack (https://make.wordpress.org/chat).

    @hcabrera Here is the link to the pastebin. https://pastebin.com/rinqBS0a

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Update: after some debugging, I found that there’s a compatibility issue with the Widget Shortcode plugin. That issue is what’s causing the popular posts widget (and some other third party widgets as well) not to be rendered at all, just like @jennbryant reported.

    I left a comment on Widget Shortcode’s support forum sharing a potential solution: Shortcode not displayed.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Marking as resolved due to inactivity.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.