The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

posts published through xmlrpc have < stripped out (9 posts)

  1. D'Arcy Norman
    Posted 7 years ago #

    I've been noticing that the WordPress iPhone app, and others that use xmlrpc, publish munged posts on my blog. The < characters in code (images, links, paragraphs...) are stripped out, leaving invalid and ugly hacked markup.

    Any ideas?

  2. kmessinger
    Forum Moderator
    Posted 7 years ago #

    You might try the normal remove plugins, etc. to narrow down the problem.

    I am using xmlrpc to publish from word with no problem including graphics, etc. so I would think a plugin problem.

  3. Joseph Scott
    Posted 7 years ago #

    This is caused by a change in libxml2, which is used by PHP to parse the XML portion of XML-RPC. Long story short, upgrade to PHP 5.2.9 and libxml2 2.7.3 and it will work again. You must upgrade both, not just one, in order for things to be fixed. For the longer story you can read my posts on the subject:




  4. D'Arcy Norman
    Posted 7 years ago #

    I just set up a fresh copy of WordPress 2.7.1, with nothing additional installed - just a barebones install of WordPress as distributed through wordpress.org


    It's showing the munged xmlrpc-published posts, too.

    Could there be something funky on the server? I'd assumed the xmlrpc code was pretty much self contained, so wasn't thinking it could be a server thing.

  5. kmessinger
    Forum Moderator
    Posted 7 years ago #

    If ypu want to send me the user name and password for your test install I will send a post from Word.


  6. Joseph Scott
    Posted 7 years ago #

    It's a problem with the server setup, not WordPress. The PHP configuration is using a version of libxml2 that is stripping the brackets ( < ) from the XML-RPC requests.

  7. D'Arcy Norman
    Posted 7 years ago #

    I won't be able to update either PHP or libxml2 on the shared server, but applied the suggested code from http://blog.hoofoo.net/2009/01/14/wordpress-patch-for-problamatic-libxml2-version/ and it appears to work now.

  8. Joseph Scott
    Posted 7 years ago #

    You should contact your hosting service then and let them know they are running versions of PHP/libxml2 that are known to be broken.

  9. gee_crum
    Posted 6 years ago #

    Intially I tried the WordPress Plugin LibXML2 Fix, but it did not work.

    To get it to work, I had to edit the plugin itself.To do this I had to modify the file libxml2-fix/libxml2-fix.php

    Here is what I did:

    I changed The first Line of the IF Statement





    I am assuming this first line needs to point to the current version of the library file my host is bluehost is using. This version was 2.6.26

    I tried this on a rolled back version of WordPress, 2.7 and also in 2.9.2 and I was able to see my posts submitted from Window live writer correctly each time.

Topic Closed

This topic has been closed to new replies.

About this Topic