Support » Plugin: Bogo » Posts Page Problem

  • Hello Takayuki,

    As always, let me start saying your work is amazing and beautiful. Congrats!

    I’m having some problems showing my Posts Page in other languages than the original. I set the Front Page and the Posts Page to be a Static Page. This can be done in Options > Reading.

    I have no problems showing the Front Page in the correct language. In other words, the following is working:

    mysite.com –> Front Page (front-page.php) with default language
    mysite.com/en –> Front Page with other language than the default

    However, I set my Posts Page to be my page named “Blog”. This title is by chance exactly the same in the other languages. When I navigate to my posts page when in my default language it’s working correctly but when I navigate to my posts page when in other languages than the default it prints de Front Page.

    mysite.com/blog –> Posts Page (home.php) with default language (works!)
    mysite.com/en/blog –> It prints de Front Page in the other language (in this example, english)

    I also experience some trouble with the 404 Error Page (404.php). It always show the 404 Error Page with the default language locales.

    mysite.com/a-random-non-existent-page –> it shows 404 in the default language
    mysite.com/en/a-random-non-existent-page –> it shows 404 in the default language (wrong!)

    Am I doing something wrong? Am I forgetting something? This is due to something or to some feature not already added to the plugin?

    Thank you a lot for your help!

    😀

    https://wordpress.org/plugins/bogo/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Posts Page Problem’ is closed to new replies.