Support » Fixing WordPress » Post(s) Number(s)

  • I had about 10 posts after importing some stuff from MT.
    Now when I create a new post, with the last post being #10, the next post is #102…
    …/index.php?p=102 where logically it should be …/index.php?p=11
    I did login to MySQL and change the author to all the same person – but did I do something to screw up the post numbering? If so, how would I fix this?
    Thanks in advance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • actually post number does not matter… the blog works fine anyways…
    you should consider shifting to Smart URIs using apache redirects. 🙂

    How would I go about doing that?
    Thanks.

    there is an option named permalinks…
    check in the backend.

    The permalinks option will create a set of ‘rewrite rules’ that have to be cut and pasted into a file you create called .htaccess. Put this file in your root WP folder and whammo, smart URIs. 🙂

    provided ur host is not EVIL. 🙂

    Wow, you’ve got me confused!!

    Login to wordpress,
    Click on Options
    Click on Permalinks
    Then once you are there, decide what kind of permalinks(permanent links) you want, instead of the ?p=2835r9 kind.
    Then you will get a piece of code at the bottom of the page, which you have to include in your .htaccess file.
    Simple 🙂

    ALTER TABLE wp_posts auto_increment = 0;
    I’d like to know if there’s a way to have the “real” post number of a certain post displayed (not the post_id) by the way… Is there?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Post(s) Number(s)’ is closed to new replies.