Posts not showing up on blog page (5 posts)

  1. markmcleod50
    Posted 3 years ago #

    This is my third wp site and I am running into a problem I can't figure out. I am building a new site for a community art event and whenever I create a new post, it publishes, but nothing shows up on the blog page. I've noticed that the post is missing the blog subfolder?


    Things I've checked
    permalinks, posts page is set to blog

    My own website uses the same theme, markmcleod.org, but I run two blogs there and pull them based on categories.

    Thanks for the help.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  3. markmcleod50
    Posted 3 years ago #

    I have not installed any plugins yet.

    Everything works with the Twenty Eleven theme, as well as other themes. I like the Shuttershot theme..and it works on my root website.

    I'm downloading a copy of my other website, markmcleod.org, and going to try duplicating it to that site, then adjusting for the differences.

    Thanks for your quick response

  4. markmcleod50
    Posted 3 years ago #

    Ok I found the error. After a complete reinstall and dropping everything in the database, I've narrowed the error to the Reading settings. If I set any of the pages to a static page, I get the above mentioned errors. Even if I set the front page to anything other than - select - on my blog page I will get the info from whatever was set as the front page. If i set the posts option to anything other than -select- none of my posts will show up.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    I'm sorry but this is a theme issue. Try contacting the theme's developer directly.

Topic Closed

This topic has been closed to new replies.

About this Topic