Support » Plugin: Yoast SEO » Posts not showing score

  • Resolved Deleyna

    (@deleyna)


    Since the end of February, one of my sites is no longer showing an SEO score in the posts. The client is entering a key phrase as normal. Looking at the posts, I see that it shows things like “no subheadings” when there are clearly subheadings. In fact…it seems not to be seeing the text of the post at all. Thoughts? This is a busy site and the client has used Yoast for a year now without problems. Only since the end of February is this problem happening.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I face a similar problem. While my product SEO works normally when I make changes (eg. add outbound or internal links), in my pages that’s not the case. I apply all the recommendations and the SEO doesn’t seem to recognise them.

    • This reply was modified 10 months, 2 weeks ago by shimmery.
    Plugin Support devnihil

    (@devnihil)

    @deleyna Can you please confirm you are using the most recent Yoast v13.2? You can learn more about updating here: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/

    Also, can you confirm you are using WordPress 5.3.2? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/

    ​If you update to the most current version of WordPress and Yoast SEO, does this resolve the issue with the SEO score indicator?

    If the issue is still occurring after confirming both Yoast SEO and WordPress are updated, this may be due to a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Check for conflicts.
    2. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    @shimmery Please create a new issue if you are experiencing a similar problem as this helps us in tracking as this can be caused by many different variables (WordPress version, other plugins, etc).

    Yes. Yoast 13.2, WordPress 5.3.2

    I need to test more, but coincidentally our hosting company is currently migrating the site to a new server. I’ll test after the migration and update this ticket.

    Thanks for the help. This may point me to the problem.

    I am also using version 13.2 and WordPress 5.3.2. and there are no conflicts or JavaScript errors. It’s strange because when I change for example the image alt attributes, it recognises normally the changes and from orange it becomes green for this matter. My problem is with the outbound and internal links and the keyphrases in subheadings which are red and won’t change no matter what I try.

    Server move completed. I did the check, didn’t immediately find any other conflicting plugins. I did see this error:
    SyntaxError: invalid regular expression flag s — yoast-compatibility.js:8:94

    Not sure if that helps any.

    I will report to my client that he may need to purchase support if he wants this to work, or we may need to try something else.

    Thanks for pointing me in the right direction.

    AHA — I found it. And you were right — it absolutely WAS a plugin conflict with Oxygen.

    There is a patch here: https://github.com/soflyy/oxygen-bugs-and-features/issues/516

    Everything is working well again.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Posts not showing score’ is closed to new replies.