Support » Plugin: WPML Widgets » Posts not showing after last update 1.0.5

  • Resolved fran7877

    (@fran7877)


    Hi! Thank you for this plugin, it helps me a lot. After updating wpml widget plugin to the 1.0.5 version I can’t work on my posts on my wp dashboard. If I click a post I can’t see the post and I get this:
    <<Fatal error: Call to undefined function wpml_get_active_languages() in /home/thebla40/public_html/wp-content/plugins/wpml-widgets/wpml-widgets.php on line 122.>>

    Can you help please with this?

    Kind regards,

    Fran

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeroen Sormani

    (@sormano)

    Hi Fran,

    What version of WPML are you using?

    Cheers,
    Jeroen

    Hi!

    The last one, 3.6.2.

    Kind regards,

    Fran

    Plugin Author Jeroen Sormani

    (@sormano)

    Hi,

    Thank you all for reporting this.

    I’ve not been able to replicate this error, but obviously something is going on with some the users (I don’t suspect everyone since I think then more people would’ve reported it by now).

    The error reported in the first message states that the ‘wpml_get_active_languages()’ function doesn’t exist, which is strange since I can definitely confirm it exists since version 1.3 in the WPML source, so I’m not sure why that would show up.

    Anyways, I’ve changed how the plugin is getting the list of available languages, since I can’t replicate the issue I’d like to ask you guys to help me test this.
    The updated code can be found here: https://github.com/JeroenSormani/WPML-Widgets/tree/fix-error
    If you can click the ‘Clone or download’ -> ‘Download ZIP’ it will download a copy of the plugin. Please try and manually update the plugin and give me your feedback here.

    Thank you,
    Jeroen Sormani

    Marek Jan

    (@marek_kozlowski)

    Hi @jeroen

    It installed and works fine so far. I will test on multiple languages now. Thanks for quick response and fix. 🙂 I’ll keep posted if there are any issues.

    Plugin Author Jeroen Sormani

    (@sormano)

    Thanks @marek_kozlowski,

    I’ll await the feedback from a couple others and update the plugin when its confirmed working for them too.

    @sormano
    Just a feedback.
    Update from github fixed the issue for me.
    Thanks for the quick reaction!

    #feedback

    Same issue here, with the last WPML suite version.

    Your GitHub fix did the trick, now it works.

    • This reply was modified 6 months, 3 weeks ago by  daweb.
    Plugin Author Jeroen Sormani

    (@sormano)

    Thank you all for testing it and the feedback!

    I’ve just pushed 1.0.6, it should be up in a few minutes (update notification in your dashboard within a day as usual)

    1.0.6 Appears to have fixed the problem I had. Thank you.

    rolstoeltennisjennifercoenraad

    (@rolstoeltennisjennifercoenraad)

    Hi Jeroen, I’ve activated the WPLM plugin but I don’t WPML on my dashboard. please help!
    Oh yeah I tried to update as above but nothing works!

    rolstoeltennisjennifercoenraad

    (@rolstoeltennisjennifercoenraad)

    Hi Jeroen, I’ve activated the WPLM plugin but I don’t WPML on my dashboard. please help!
    Oh yeah I tried to update as above but nothing works!
    Do I need to install an other plugin to let it work?

    Plugin Author Jeroen Sormani

    (@sormano)

    Hi,

    I’m not sure what you mean.

    It doesn’t sound like it is related to my WPML Widgets plugin at this moment, but if it is, please create a separate support thread and elaborate what you mean (it doesn’t sound related to this topic either).

    Thank you,
    Jeroen

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Posts not showing after last update 1.0.5’ is closed to new replies.