WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] posts not displaying in theme after 2.1 upgrade

[Resolved] posts not displaying in theme after 2.1 upgrade

  • I just upgraded from 2.0.7 to 2.1. The theme I was using was working perfect in 2.0.7. I uploaded all the 2.1 files except wp-content, over-written the exiting ones. The process went fine but when I went to my index page it gave me the “Not Found” – Search Results page. I see all my entries listed under categories, etc. I even put in a new post which can be seen on the feed but not the actual page. When I click the permalinks for a post I get the “Sorry, no posts matched your criteria.”

    I applied other themes to my blog and they all work fine with it. The only thing I can think of was the theme was activated when I upgraded. I tried copying the theme and upgrading under a different theme name but I got the same problem. Anyone have any idea?

Viewing 14 replies - 1 through 14 (of 14 total)
  • You need to upgrade your database, just try logging in and it will tell you that you need to upgrade. Just follow the instructions.

    Looking into it now. But why would everything work fine with other themes if it was my database?

    Some themes use custom loops that get information straight from the database, rather than going through WordPress.

    I have created some custom templates for this theme and when activated they pull the posts using the loop, but the main index page as well as all permalinks pull up a “no search results found” item. I am completely stumped.

    Completely perplexed on this one. The blog that I upgraded is here. You can see what im talking about. This is just a test blog so I can play around with theme edits.

    http://patricksarni.com/blogtest/wordpress/

    here is a page that uses a custom template with two loops in it. You can see that this calls up the posts but nothing else does. Any help would be greatly appreciated.

    http://patricksarni.com/blogtest/wordpress/about-2/

    **(note: header images link to actual website with very similar theme)**

    I applied other themes to my blog and they all work fine with it.

    This tells there is something in the Loop(s) used in that theme that is not compatible with 2.1.
    Best thing > post your index.php to http://wordpress.pastebin.ca and somebody can take a look at it.

    Its posted. I compared the index to a couple other ones to themes that worked. Did a little replacing but still got nothing out of it. If someone could take a look, I’m desperate to figure this out.

    http://wordpress.pastebin.ca/328475

    Try deleting <?php get_cat_icon();?>

    Note to myself: ALWAYS deactivate all the plugins before trying anything else!

    That was actually one of the first things i tried. Plugins were deactivated when I installed. Still sifting through looking for a solution.

    Did you delete the code line as I said?

    yes, I have put it back in after seeing it didnt fix the problem. That plugin actually plays correctly when using this template.

    http://patricksarni.com/blogtest/wordpress/about-2/

    Thought it might be some other plugins so I have just deleted a bunch or deactivated all of them with no help. Ive been trying everything I can think of but nothing seems to be doing the trick.

    Perhaps it was just an upload problem?

    Well, I took your code from the pastebin, put it in a similar theme (default, because yours is a default clone) and it didn’t display anything. Deleted that line – and everything came back to normal.

    Took that line out and deleted the plugin with no help. Then took default theme again and using dreamweaver copy and pasted css, index, sidebar, etc replacing existing files (all which do not include the get_icon tag) Uploaded under different theme name etc, still got the same problem.

    Im starting to go crazy on this one.

    UPDATE: Found the problem. It was the sidebar. Instead of using the default:

    <h2>Recent Posts</h2>

      <?php get_archives(‘postbypost’,’10’,’custom’,’

    • ‘,’
    • ‘); ?>

    I was using a cheat to only display topics from certain categories:

  • <h2>Recent Rants</h2>

  • Apparently 2.1 doesnt like this. I will have to figure out another way to fix the sidebar the way I want but as far as this problem goes, things are resolved.

    Thanks for all your help moshu.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] posts not displaying in theme after 2.1 upgrade’ is closed to new replies.