Support » Fixing WordPress » Posts not displaying after setting static front page

  • Resolved stevenswv


    While setting up my site I realized I didn’t want to have my blog or “posts” to show up on the front page of the site. I would like to have my posts (all of them) only display on a separate page, in this case cleverly named…blog.

    So, after a short search I found the easy way to accomplish this was to go to settings>reading> to choose a “static” page as my front page and do the same for my “posts page”.

    After doing so and setting up a few dummy postings my “blog” is currently blank. I’ve searched quite a bit through the forum and see that using the method of catagorizing the posts and them assigning them to only display on certain pages would work in my case but I find it to be a little on the unnecessary side since I want all of my posts to show on only one page…which unfortunately happens to NOT be the main front page.

    The posts will display if I go to their specific url or click on them in the sidebar list but not on their assigned page. Also, the “blog” page I set them to display on is setup with nothing but a title.

    So, I would appreciate any tips, hints, plug-ins, slap in the head, etc. to figure this all out.

    On WP2.8 using Blue Black 2.7.5 Theme


Viewing 3 replies - 1 through 3 (of 3 total)
  • Could be the theme, could be a plugin.

    Change to the WordPress Default theme and see if it works. If that doesn’t fix it deactivate plugins.

    Wow that really pisses me off…I spent far too much time figuring this was a legitimate problem and not just a theme flaw!

    Thanks Mike I appreciate your help!

    Did you ever solve this? I’m having the same issue, and I don’t know what I can change in the the theme to fix it. Something in the index.php? Any help would be greatly appreciated.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Posts not displaying after setting static front page’ is closed to new replies.