Support » Fixing WordPress » Posts not displayed on index.php

  • Resolved nlamont

    (@nlamont)


    I’m new to this, but I had a previous attempt at setting up WordPress on my hosting provder server. It worked OK but at the time I went off and forgot about it.

    Returning to it I found I had created three pages and half a dozen posts. It all worked OK except that when I went to http://www.mysite.com/wordpress/ I always got one of the pages, not any of the posts. They were available in the side menu listed under recent posts, categories etc. All those links worked. I then deleted the three pages thinking that would start my posts appearing but it doesn’t. In the WordPress default theme, I get the correct header and footer, and the side panel and its links all work but the main content area displays 404 file not found. In some other themes it says ‘Sorry there were no posts to match your criteria’ as if I’d put in a search.

    Can anyone advise me how to fix this without clearing the database and reinstalling from scratch? (I’m willing to do this but I expect there’s an easiesr way.)

Viewing 15 replies - 1 through 15 (of 21 total)
  • esmi

    (@esmi)

    Forum Moderator

    Start by activating the Twenty Eleven theme. What do you get on the blog’s front page?

    Thanks for replying so quickly. I get ‘This is somewhat embarrassing, isn’t it?It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.’ – below this it displays links to all my posts, categories etc, all of which individually work fine.

    Any other info I can give you?

    esmi

    (@esmi)

    Forum Moderator

    OK – without changing the theme, create & publish a test post. Now what do you see?

    Exactly the same except that the title of the post appears top of the ‘recent posts’ list. Still the ’embarrassing’ message in the main area.

    esmi

    (@esmi)

    Forum Moderator

    Site url?

    esmi

    (@esmi)

    Forum Moderator

    What do you have set for your front page in Settings-> Reading?

    Settings > Reading:

    Blog pages show at most 10 posts
    Syndication feeds show the most recent 10 items
    For each article in a feed, show full text

    Encoding for pages and feeds utf-8

    I don’t know if it’ll help but the majority of the posts are imported from TypePad. Doing this didn’t make any difference in that it was always a Page that showed on the home page rather than posts. The pages are now deleted, but it looks like the home page still wants a page rather than a post. I started manually deleting the Typepad ones in case they had corrupted it but there were too many. Also new posts I make appear OK in the archives and categories so I think the problem is in the home page.

    esmi

    (@esmi)

    Forum Moderator

    What do you have set for your “Front page display” section in Settings->Reading?

    Sorry, Esmi, there’s nothing saying ‘Front page display’. What I quoted above is all there is.

    If there’s a way to private message you or an email address I’m happy for you to have my admin ID and pw as I’m just trying out the blog.

    esmi

    (@esmi)

    Forum Moderator

    Have you:

    – deactivated all plugins to see if this resolves the problem.
    – switched to the Twenty Eleven theme

    Ah! There was a plugin called ‘Akismet’ activated. When I deactivated that (I don’t even know where it came from), the blog behaves correctly. Apologies, I should have thought of that but I’ll plead the newbie amendment!

    Thanks very much for your help, Esmi. It’s given me an idea what to do when I get further into this and things don’t work.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Posts not displayed on index.php’ is closed to new replies.