WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Posts not aligning properly in IE

[Resolved] Posts not aligning properly in IE

  • In IE 9, all of a sudden, today, my post content <div> is out of alignment, causing all of my content to be pushed between the content div and the sidebar.

    I have a very modified theme, but nothing has changed on that end, and I’ve even uploaded backups of files such as single.php trying to make sure.

    I have checked multiple things I know to do, and can’t seem to figure out why. Could it have been the latest wordpress update? I know I installed it either yesterday or today.

    It appears fine in Chrome.

    Here’s a link to a post which shows the behavior http://www.kingsporthousing.org/?p=630

    Thanks in advance for any advice.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Andrew Nevins
    Forum moderator

    @anevins

    If you’re experiencing browser compatibility issues, you should first make sure your webpages validate to W3C standards.

    Thanks Andrew, but I’ve checked and don’t really see anything that would be causing it. Especially since it just started all of a sudden…

    Can anyone verify that the alignment is off in IE, and it’s not just my PC or browser?

    Its just you …however there is a line that isnt displaying at the top for me…just make sure that it is all one element.

    Thanks Nickkos…

    I feel kind of dumb, but I figured out the problem. At some point today, I accidentally turned on Compatibility mode in IE, and finally caught it by looking in the Development Tools…

    Once I clicked off of Compat Mode, all is well again.

    Yeah compat mode is sucks in the future you can `if (IE COMPAT) then {
    fix IE Crap
    }`

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Posts not aligning properly in IE’ is closed to new replies.