Support » Plugin: Polylang » Posts in different languages are not connected

  • Hi,

    I always click on the “+” language sign when I create post in another language. But I found out now all the extra langue posts become individual posts, not connected with language switcher. I thought it was my mistake so I even deleted posts and copy-pasted all over again but the problem persists.

Viewing 9 replies - 1 through 9 (of 9 total)
  • When you create a post, and you are done with it, in the first language, you do not get out to create another one. From within that post, you go in the Languages box, in the right column and click on the pencil, next to the other flag, you want to translate that post into. A new window will open, in which you create your post, in the second language. In that way, all posts for that topic, are synchronized.

    I have similar problem – it appeared recently, in the similar time when I upgraded WordPress to ver 5.
    I can not associate translation to any post. I click on +, I create another post in another language and save and publish, but then when I look at frontend the post is not linked to the translation.
    I tried to desactivate Gutenberg, Visual Composer and the vast majority of plugins but still problem persists.

    Thread Starter hsultd

    (@hsultd)

    @sv1cec I followed the steps you mentioned exactly. Many times the plus button inside the post doesn’t even let you create a post, I have to refresh a few times in order to do that, and still the posts that are created through the “+”language sign inside the post are not connected to the 1st created post.

    • This reply was modified 3 years, 4 months ago by hsultd.

    When you see all posts, does the table contains the second one you created? If you go in the first post, in the default language, in the right column, in the “Languages” box, do you see the titles you gave to the other languages posts? If you click on on the pencil, next to the alternate language flag, do you get to see the alternate language post and be able to edit it?

    @gjudycki, I am sorry, I am not using WordPress 5, so I can’t help much. But typically, the same questions apply to you.

    Thread Starter hsultd

    (@hsultd)

    @sv1cec I did the right procedure, I’ve been using Polylang for 4 years and I know how to create linked content. But now all the translated posts are not linked to the default language content, it happened after the wp updates 2 versions ago.

    I wish I could share some screen shot but I don’t see image post options here.

    Well, I just updated our development site to the latest WP version, I checked a listing or two, and a couple of pages, I didn’t notice any problem, as far as the translations are concerned. Now, I have to figure out how to go back to our classic editor, that block-based thing makes me crazy!

    Thread Starter hsultd

    (@hsultd)

    Ha…to be honest, i also hated the gutenberg blocks in the beginning and download the block gutenberg plugin. But then I tried to use those blocks and now I got used to it.

    Thread Starter hsultd

    (@hsultd)

    I found out the problem is caused by Site Original page builder.
    I will let them know about it and hope they fix it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Posts in different languages are not connected’ is closed to new replies.