Support » Plugin: Revive Old Posts - Social Media Auto Post and Scheduling Plugin » Posts get re-shared even with “Share More Than Once” not ticked

  • Resolved wpguillaume

    (@wpguillaume)


    Hello,

    Until very recently, auto-posting did not work for us, so I manually shared posts with the instant sharing feature.

    Now auto-posting seems to work (https://wordpress.org/support/topic/auto-posting-doesnt-work-manual-posting-does/), but posts that were manually shared before got shared once again, even though the “Share More Than Once” setting is not ticked.

    Our settings are:
    Minimum interval between shares: 5 hours
    Minimum post age: 2 days
    Maximum post age: 12 days
    Number of posts: 1
    Share more than once? NOT checked

    I stopped the autoshare for now until I can solve this. I tried starting it again, and saw all posts aged between 2 and 12 listed in the queue, so I stopped it again right away.

    Please tell me if you need more info.

    Thank you for any pointers or solution to this! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    Hi there, the queue gets created everytime you click “Start Sharing” or if you click the “Refresh Queue” button on the sharing queue tab.

    Even though you manually shared a post, if it falls in the filters it will still get shared by ROP. The “Share More than Once” option only applies to posts shared on autopilot by the plugin.

    Thread Starter wpguillaume

    (@wpguillaume)

    Hi, thank you for this confirmation.

    In our case, because we don’t post much, the workaround is to first stop sharing, then wait for at least 12 days after the most recent post was manually shared, then start sharing again.

    Also it means we should stop sharing manually in the future, so we never double-share again. 🙂

    Thank you again for this plugin, it’s a great time-saver.

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @wpguillaume You don’t have to go to the plugin dashboard after 12 days to click “start sharing”. You can actually leave the plugin as is and just go back to the posts that you posted and use the “Share immediately using Revive Old Posts” checkbox AKA the “Post on publish” feature; The meta box also shows up on Posts that have been published already, see this screenshot: https://vertis.d.pr/DSdxMp

    So when you want to share some older posts…You can just go to those posts, click on the accounts you want it to post to and click “Update”.

    Please consider leaving the plugin a review if you haven’t already: https://wordpress.org/support/plugin/tweet-old-post/reviews/ 🙂 it helps a ton

    Thread Starter wpguillaume

    (@wpguillaume)

    @uriahs-victor

    Our use case is more like this:

    Someone in the team publishes a post on our website. Everyone in the team receives a mail alert about it, so they can fix the post if they want.
    Once 2 days have passed, ROP is supposed to share the post to Facebook/Twitter.

    If we have a post that needs sharing faster than 2 days later, then “Share immediately” would be nice to use. But then, same post gets reshared, which we don’t want.
    Or, because I still can’t get auto-posting to work properly, if I manually share a post, I can’t activate auto-posting until the post is 12 days old, if I don’t want it to be reshared.
    Hoping I’m making sense here. 🙂

    (And indeed, I thought the auto-posting issue was solved, but it looks like it’s not: https://wordpress.org/support/topic/auto-posting-doesnt-work-manual-posting-does/#post-14550835.)

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @wpguillaume Please send us a support ticket here with your issue: https://revive.social/direct-support/

    Thread Starter wpguillaume

    (@wpguillaume)

    @uriahs-victor As I see it,
    solving the issue in this thread would take the form of a feature request: that posts manually shared don’t get re-shared afterwards if “Share More Than Once” is not ticked. Should I send a support ticket about this?
    Or are you referring to the issue about auto-posting vs. manual? If it’s the latest, I already sent a support ticket with a link to this thread (https://wordpress.org/support/topic/auto-posting-doesnt-work-manual-posting-does/) about a month ago.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.