WordPress.org

Support

Support » Plugins and Hacks » Posts from ReBlog are reposted without dashes

Posts from ReBlog are reposted without dashes

  • topwebnewscom
    Member

    @topwebnewscom

    Hi,

    I am using WP 2 and ReBlog plug-in. I noticed that posts from the ReBlog RSS output are posted on WP without dashes – the title (permalink) is corrupted this way.

    Anyone with a solution?

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • topwebnewscom
    Member

    @topwebnewscom

    anybody?

    topwebnewscom
    Member

    @topwebnewscom

    Solved my problem using FeedWordPress.
    Thanks anyway.

    I’m having the same problem – putting the dashes in manually is a royal pain in the bazoo. Thanks for the suggestion to try FeedWordPress.

    Before changing to FeedWordPress, I decided to try a little harder to solve the reBlog problem, and sure enough I found a solution (or should I say, I found someone else’s solution and used it). This works for the no-dashes-in-the-permalinks problem:

    Look for these 3 lines:
    mysql_real_escape_string($item[‘title’]),
    mysql_real_escape_string(format_to_post(balanceTags($item[‘summary’]))),
    mysql_real_escape_string($item[‘title’]),

    Change the last line to:
    sanitize_title($item[‘title’]),

    Those 3 lines occur in 2 different places in the reblog.php plugin file, and you will need to change the last line in each occurance.

    MY NOTE: when it says reblog.php take that to mean the Refeed-Plugin.php in the plugins folder (which is in the wp-content folder of your WordPress files).

    Source: http://sourceforge.net/forum/message.php?msg_id=2882010
    originally posted by Steve Jenkins

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Posts from ReBlog are reposted without dashes’ is closed to new replies.