Support » Plugin: YourChannel: Everything you want in a YouTube plugin. » Posts don’t show in pages (but DO show in preview)

  • This is odd. On my site, learnlinux.tv, none of the pages show YouTube videos. If I go into settings, theme settings, and then preview, the posts show just fine.

    I tried clicking the “clear cache” button, but clicking it does nothing (there’s no visual indicator that clicking on it did anything).

    It was working fine, but I removed some Google Adsense ad units and then after I did that, it stopped working.

    Is there any reason why YouTube posts would show in preview but not on the actual live site?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author plugin.builders

    (@pluginbuilders)

    Hi, your theme doesn’t have jQuery, YourChannel needs it. That ad plugin must have been loading jQuery before.

    It’s fixed now. I don’t know how to enable jQuery, I’m not a developer. But I noticed that when I enable the “Ad Blocker Notify Lite” plugin, it fixes it. Perhaps that plugin triggers jQuery to enable? I’ve removed my Google Adsense ads since that doesn’t result in barely any revenue, so I disabled the “Ad Blocker Notify Lite” plugin since I don’t need it now that I don’t have those ads.

    For now, I’ve re-enabled the plugin even though I don’t need it, but if there’s some documentation on how to enable jQuery, let me know.

    Should I file a bug? The Ad Blocker Notify Lite plugin seems to trigger jQuery to be enabled. Shouldn’t YourChannel also trigger jQuery to be enabled since it seems to need it? I would think the YourChannel plugin should be enabling whatever it needs.

    Thanks!

    Plugin Author plugin.builders

    (@pluginbuilders)

    Hi, yes we’ll make YourChannel load jQuery on its own in the next version.
    You can check this post: https://generatepress.com/forums/topic/shortcode-does-not-show-in-front-end/#post-475755

    Here’s the code you should put in your theme’s functions.php file:

    add_action( 'wp_enqueue_scripts', 'tu_load_jquery' );
    function tu_load_jquery() {
        wp_enqueue_script( 'jquery' );
    }

    Thank you so much!

    svitlana1

    (@svitlana1)

    None of my posts show on any of the pages. I tried to switch to different themes and disabled all of the plugins. Nothing helped. Tried to clear cache, didn’t work either.
    Please help.

    Plugin Author plugin.builders

    (@pluginbuilders)

    Hi, please send me link to your page. You can also send it to our email: support @ plugin.builders

    svitlana1

    (@svitlana1)

    lifeofhomeschoolers.com

    Thank you.

    Plugin Author plugin.builders

    (@pluginbuilders)

    Which page do you have the shortcode in? There’s nothing in the home page.

    svitlana1

    (@svitlana1)

    Yes, first posts would not appear only in a Blog page so I tried to remove Blog page and make my homepage as a blog page. I erased everything from the Homepage. When it didn’t help I added back my Blog page. However the problem spread to the rest of the pages, so I never got back to fix my home page to what it used to be.
    I supposed to have posts in my Blog page, and Resources page mostly.

    svitlana1

    (@svitlana1)

    Where can I find the shortcode you are looking for? And should I reactivate my plugins?
    I am sorry, I am not techy at all. But I am a quick learner, just tell me what to do.

    Plugin Author plugin.builders

    (@pluginbuilders)

    Did you follow the guide here: https://plugin.builders/yourchannel-setup/ ?
    YourChannel will then generate a shortcode that looks like: [yourchannel user=”your_username“], copy paste it in your post.

    svitlana1

    (@svitlana1)

    I haven’t started to build my Youtube channel, yet. Or is this procedure has to be followed for blog posts as well?

    svitlana1

    (@svitlana1)

    I don’t have a section You Channel in my wp dashboard.
    The problem with my site is that my blog posts would not appear in my pages.

    Plugin Author plugin.builders

    (@pluginbuilders)

    You haven’t installed YourChannel? YourChannel page is in Settings > YourChannel.

    Or are you talking about WordPress posts themselves?

    Plugin Author plugin.builders

    (@pluginbuilders)

    It seems like your issue is not with YourChannel but with WordPress itself or your theme. Look for your theme’s support forums.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.