Support » Fixing WordPress » Posts displayed bug?

  • I’ve had my ‘post displayed’ option set to 1 forever. Now, all of a sudden, it’s displaying 2 entries on the front page. I’ve tried changing it to 2, then back to one, but it doesn’t change. Additionally, I just tried changing it to 3, but it’s still displaying 2 entries.
    Because I update from CVS every day, I’m sure exactly when this happened (I only noticed it yesterday.) Also, I installed MtDewVirus’ Stats, latest comments, and new archives hack yesterday (those are the only hacks I have installed), so I’m not sure if one of those is creating this behavior.
    Can anybody help with this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Cena,
    I think for the new archives hack you had to set it to display “days”, could that be what it is doing? Simply displaying 1 days worth? Nothing in those hacks should affect this at all, especially since the archives hack is just a few functions in the hacks file and arch.php is a completely different file.

    Well, it’s displaying TWO entries, when I have set to display 1. It continues to display two entries, no matter what number I input for ‘posts displayed’. And yes, I did change the display to ‘days’ to accomodate the hack.
    It’s a mystery. 🙂

    Okay, after further fiddling around, I’ve discovered that what seems to be happening is that WP is reading multiple posts on the same date as ONE post, at least in terms of the ‘posts displayed’ function.
    The two posts in question were both entered on the same date. A minute ago, I was playing around and entered a test entry, which displayed correctly (according to my options) as a single entry.

    You have it set to days and the number to 1, so it shows all posts for 1 day. If set to 2, it will show all posts for 2 days, etc. It doesn’t matter how many posts there were on those days. That was one problem I had when I came up with the archive hack. I don’t know any other way to get around it, but it needs to be set to days or else the $posts_per_page = ‘-1’; line in arch.php doesn’t work.
    If anyone knows a secret, please share! 🙂

    Ah! I unnerstan, man.
    Hey…I see in the latest cvs there’s a little rudimentary sub-cat action happenin’. You’ll need to gear up for that, too. 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Posts displayed bug?’ is closed to new replies.