WordPress.org

Support

Support » How-To and Troubleshooting » Posts created by w.bloggar not displayed

Posts created by w.bloggar not displayed

  • Hi everybody,
    I have a running WP installation and everything works fine so far. The only thing not working is using the xml-rpc interface with w.bloggar.
    Symptomps:
    I can publish and edit posts with w.bloggar, however they don’t appear on the blog. They are however visible in the “edit” view of the backend. Posts created with the backend are visible, and I can’t find any differences between them and the ones created by w.bloggar. Editing the w.bloggar created ones in the backend, changing their status to draft and back to published makes them visible in the frontend too.
    What I tried:
    I tested both the release candidate for 1.2 and the current cvs version. I checked the database for any differences between the post records, but could not find any. I tried different xml-rpc apis (moveableType, Blogger, metaWeblog), but no differences.
    Any ideas or suggestions for this problem?

Viewing 13 replies - 1 through 13 (of 13 total)
  • u chose a category while posting?
    it give me error if no cat is selected…

    I’m having the very same problem, and it also appears with BloGTK under Linux as well. It appears as though the XML-RPC code in 1.2 is broken in regards to the Movable Type API.

    I did the same tests that gloeglm did, and I get the same results. The fault is somewhere in the publish option with the XML-RPC interface. The posts are being entered, but even if you specify the publish option, they’re being handled as drafts even though the system seems to believe they have been published.

    This seems to be because of time-zone related issuse. Posts created through the backend have post_date = post_date_gmt = 19:00, Posts created by w.bloggar have post_date_gmt =19:00, post_date=21:00 in my case. Both server and local PC time are 21:00
    I will incestigate some further.

    I got this fixed:
    Theoretically, the “Times in the weblog should differ by” option on the “general options” page should solve this (setting this to 2 in my case). However this was never saved due to a missing row in the database.
    Manually inserting this by
    INSERT INTO wp_options ( option_id , blog_id , option_name , option_can_override , option_type , option_value , option_width , option_height , option_description , option_admin_level )
    VALUES (
    ”, ‘0’, ‘gmt_offset’, ‘Y’, ‘1’, ‘2’, ’20’, ‘8’, ”, ‘1’
    );
    fixed this. Posts from w.bloggar now immediately appear in the blog.

    Thank you so much. I was pulling my hair out not being able to use this wonderful app any more.
    Your solution worked like a charm!

    try zempt instead. been working perfectly so far for me.
    was having issues with wbloggar, too, but didnt bother to troubleshoot.

    can anyone else using w.bloggar comment w/ wp 1.2?

    I’m having this same problem with Zempt and w.bloggar. I’ve already inserted the code listed by gloeglm. Any other suggestions on how to fix this?

    another try to see if anyone else has this working after an upgrade to 1.2…

    http://www.macewan.org/index.php?m=200406#post-70
    not sure what version of wp i’m using but it’s the latest blogtk

    not sure what version of wp i’m using but it’s the latest blogtk

    Hi!
    I am trying to post with blogtk-1.0 and wp1.3.alpha3 but without success.
    blogtk connects to blog server but displays no categories and ‘post entry’ results in nothing 🙁
    Any hint?
    Sincerely,
    Gour

    Anonymous

    I believe xml-rpc is being completely redone for 1.3, so wait a few months and all your problems should be over 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Posts created by w.bloggar not displayed’ is closed to new replies.