Support » Fixing WordPress » Posts being indexed in Google by IDs, not headlines

  • ckids

    (@ckids)


    I’m having trouble figuring out how to get Google to index posts by their titles/headlines instead of as [url]/p=

    I created a site map and Google webmaster tools shows no errors. I’ve also installed an SEO plugin.

    I’ve never had this problem before with any WP blogs and can’t figure out what I’ve misconfigured.

    Anyone know exactly where/how this is controlled so that I can get the headlines to show up instead of just the url/id #?

Viewing 11 replies - 1 through 11 (of 11 total)
  • whooami

    (@whooami)

    Member

    dont you think we might need the url to your blog?

    ckids

    (@ckids)

    Sorry… brain fried by now.

    databreaches.net

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Your URL’s are the ?p=xxx type. If you want them different, go to the Settings->Permalinks page.

    ckids

    (@ckids)

    Thanks, Otto. I have another WP blog (earlier version) that uses ?p=xxx urls and Google indexes them by headline and not ?p=xxx, so I didn’t think that could be the issue here.

    I’ll try it, though.

    ckids

    (@ckids)

    That didn’t seem to accomplish what I want to accomplish.

    Here’s my other blog’s results in Google: http://tinyurl.com/8pnoez The permalinks for that blog are set for default, ?p=

    So how come those entries show up correctly using permalinks default and using permalinks default in 2.7 is not showing up similarly?

    whooami

    (@whooami)

    Member

    its the title tags.

    look at this:

    link edited by whoo

    thats what is inside the title tags.

    and if you compare the second entry on that page, to the second entry on this page:

    link edited by whoo

    theyre indexed exactly the same way.

    Can give an example of what you are seeing?

    ckids

    (@ckids)

    If you click on the link for the first one to see other results that were omitted and scroll down, you’ll see entries like this:

    http://www.databreaches.net/?p=109
    Similar pages

    http://www.databreaches.net/?p=128
    Similar pages

    http://www.databreaches.net/?p=27
    Similar pages

    No titles at all.

    It looks like one or two posts from the other day got indexed with titles but other posts did not get indexed with titles, and I can’t figure out why or how to fix it.

    whooami

    (@whooami)

    Member

    I see. thats more of a google thing, really I guess.

    ckids

    (@ckids)

    I don’t know if it’s Google or WP, which is why I asked here.

    Thanks for trying to help.

    whooami

    (@whooami)

    Member

    actually,

    look at this:

    TD Banknorth notifies over 3,000 customers of stolen data

    view your source.

    you have duplicate meta tags.

    get an account on google webmaster tools, you would be told that.

    ckids

    (@ckids)

    I have an account on webmaster tools. And it reported no errors. Weird.

    I’ll fix that, though, by deleting the upper set.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Posts being indexed in Google by IDs, not headlines’ is closed to new replies.