Support » Plugin: Postie » Posts are Scheduled

  • Resolved detapa

    (@detapa)


    Hi Wayne,

    On my site, incoming Postie posts are showing up as ‘scheduled’, rather than immediately published.
    My site is configured on UTC+2
    I tried combinations of ‘Ignore Email Date’ , ‘Use Postie Time Correction’ and ‘Postie Time Correction’, but posts are always showing up as ‘scheduled’.

    Here you are some deubgs,

    Array
    (
        [0] => WP_Post Object
            (
                [ID] => 2225
                [post_author] => 2
                [post_date] => 2017-05-19 20:26:07
                [post_date_gmt] => 2017-05-19 18:26:07
                [post_content] => 
                [post_title] => IMG_2397
                [post_excerpt] => 
                [post_status] => inherit
                [comment_status] => open
                [ping_status] => closed
                [post_password] => 
                [post_name] => img_2397
                [to_ping] => 
                [pinged] => 
                [post_modified] => 2017-05-19 20:26:07
                [post_modified_gmt] => 2017-05-19 18:26:07
                [post_content_filtered] => 
                [post_parent] => 2224
                [guid] => http://vigoteimporta.com/wp-content/uploads/2017/05/IMG_2397.png
                [menu_order] => 0
                [post_type] => attachment
                [post_mime_type] => image/png
                [comment_count] => 0
                [filter] => raw
            )
    
    )
    PostEmail: Post postie_post_before filter
    Array
    (
        [post_author] => 2
        [comment_author] => xxxxx
        [comment_author_url] => 
        [user_ID] => 
        [email_author] => xxxxx@icloud.com
        [post_date] => 2017-05-19T20:26:18+00:00
        [post_date_gmt] => 2017-05-19 20:26:18
        [post_content] => 
    <a href="http://vigoteimporta.com/?attachment_id=2225"><img src="http://vigoteimporta.com/wp-content/uploads/2017/05/IMG_2397-169x300.png" alt="{CAPTION}" width="169px" height="300px" class="alignnone size-medium wp-image-2225" /></a><br />
     
        [post_title] => Festival Surfing the Lerez en A Illa das Esculturas Pontevedra el 17/06/2017
        [post_type] => tribe_events
        [ping_status] => open
        [post_category] => Array
            (
                [0] => 216
            )
    
        [tags_input] => Array
            (
            )
    
        [comment_status] => open
        [post_name] => Festival Surfing the Lerez en A Illa das Esculturas Pontevedra el 17/06/2017
        [post_excerpt] => 
        [ID] => 2224
        [post_status] => tribe-ea-success
    )
    WP_Post Object
    (
        [ID] => 2224
        [post_author] => 2
        [post_date] => 2017-05-19 20:26:18
        [post_date_gmt] => 2017-05-19 20:26:18
        [post_content] => 
    <a href="http://vigoteimporta.com/?attachment_id=2225"><img src="http://vigoteimporta.com/wp-content/uploads/2017/05/IMG_2397-169x300.png" alt="{CAPTION}" width="169px" height="300px" class="alignnone size-medium wp-image-2225" /></a><br />
     
        [post_title] => Festival Surfing the Lerez en A Illa das Esculturas Pontevedra el 17/06/2017
        [post_excerpt] => 
        [post_status] => tribe-ea-success
        [comment_status] => open
        [ping_status] => open
        [post_password] => 
        [post_name] => festival-surfing-the-lerez-en-a-illa-das-esculturas-pontevedra-el-17062017
        [to_ping] => 
        [pinged] => 
        [post_modified] => 2017-05-19 20:26:18
        [post_modified_gmt] => 2017-05-19 18:26:18
        [post_content_filtered] => 
        [post_parent] => 0
        [guid] => http://vigoteimporta.com/?p=2224
        [menu_order] => 0
        [post_type] => tribe_events
        [post_mime_type] => 
        [comment_count] => 0
        [filter] => raw
    )

    or

    PostEmail: Post postie_post_before filter
    Array
    (
        [post_author] => 2
        [comment_author] => Alejandro
        [comment_author_url] => 
        [user_ID] => 2
        [email_author] => xxxxx@gmail.com
        [post_date] => 2017-05-19T20:05:37+00:00
        [post_date_gmt] => 2017-05-19 20:05:37
        [post_content] => test body
        [post_title] => test
        [post_type] => tribe_events
        [ping_status] => open
        [post_category] => Array
            (
                [0] => 216
            )
    
        [tags_input] => Array
            (
            )
    
        [comment_status] => open
        [post_name] => test
        [post_excerpt] => 
        [ID] => 2218
        [post_status] => tribe-ea-success
    )
    PostEmail: resulting post
    WP_Post Object
    (
        [ID] => 2218
        [post_author] => 2
        [post_date] => 2017-05-19 20:05:37
        [post_date_gmt] => 2017-05-19 20:05:37
        [post_content] => test body
        [post_title] => test
        [post_excerpt] => 
        [post_status] => tribe-ea-success
        [comment_status] => open
        [ping_status] => open
        [post_password] => 
        [post_name] => test
        [to_ping] => 
        [pinged] => 
        [post_modified] => 2017-05-19 20:05:37
        [post_modified_gmt] => 2017-05-19 18:05:37
        [post_content_filtered] => 
        [post_parent] => 0
        [guid] => http://vigoteimporta.com/?p=2218
        [menu_order] => 0
        [post_type] => tribe_events
        [post_mime_type] => 
        [comment_count] => 0
        [filter] => raw
    )

    Thanks in advance

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Please install and activate the Support addon https://wordpress.org/support/plugin/postie

    I need the additional information it gathers to diagnose the issue.

    In my case http://www.werun4all this problem goes away (don’t know if I can call it solved) if I go to WordPress Settings > General and choose for Time-zone “Amsterdam” instead of UTC+2.

    The UTC+2 setting was pre-set by our hosting provider STRATO. During summer daylight savings time Amsterdam = UTC+2 but apparently it works different for Postie. Only if I use “Amsterdam” and “Ignore Email date: Yes” the posts-by-email get posted immediately with the time they arrived.

    • This reply was modified 3 years, 7 months ago by willemb2. Reason: typo
    • This reply was modified 3 years, 7 months ago by willemb2.
    • This reply was modified 3 years, 7 months ago by willemb2. Reason: fix URL
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Posts are Scheduled’ is closed to new replies.