Support » Plugin: WP User Frontend » Posts are not showing up anywhere

  • I would like to use this WP User Frontend so landlord association members can easily post their own rentals on the website. I have set up the default post category as Rentals, I currently have both a page with posts for Rental Listings.

    I have a test post set up with a regular post which shows up fine in both the pages, as well as a test post set up through the plugin on the New Property page, this post does not show up anywhere but the Dashboard page, where I can edit it, but when I try to view it using the title permalink it takes me back to add a new post…when logged in as admin.

    After submitting a New Property post logged in as an author in a separate user account it says “Sorry, no such page,” but when I go to dashboard it shows up there, I can edit it and delete it, but clicking on the permalink title errors out to “Sorry, no such page” message again. This post does not show up in either of the Rental Listing pages either.

    I’ve tested on both Firefox and Chrome, I’m using Weaver II theme, but tested on TwentyTwelve, same results.

    The site is at Any suggestions?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Not really sure for the info you have given.

    Have you set up your permalinks correctly.

    “You need to set your permalink custom structure to at least contain /%postname%/ before WP User Frontend will work properly.”

    Else try disabling other plugins with a default WordPress theme.


    My permalinks are set to postname. I disabled all other plugins and it is now set to default Twenty Eleven theme.

    The post I made with wpuf still doesn’t show up anywhere except in the wpuf dashboard page, where I can click to edit but when I click the title permalink the page is not found.

    Is there supposed to be a shortcode that I put on the page that I want it to show up on, or does it just show up on a posts page?

    You need to do a couple of things.

    1. One have a edit page with the [wpuf_edit] shortcode
    2. Set the option ‘Edit Page’ in the ‘Options’ tab to that page
    3. Set the option ”Override the post edit link’, ‘ in the ‘Options’ tab to ‘Yes’


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Posts are not showing up anywhere’ is closed to new replies.