Support » Fixing WordPress » Posts 404ing after permalink change

  • I recently downloaded and installed wordpress 2.7.1. Every attempt I have made to change my permalink structure has been met with a 404 page appearing where all of my posts should be located according to the permalink change.

    I had assumed that maybe the update was just not taking hold anywhere other than to the links on the main page. I changed the permalink structure and attempted to visit the post at the default ?p=123, it also returned a 404 error. The only way to make my posts visible on their own page was to return my permalinks setting to its default.

    Any ideas? Let me know if you would like me to try / test something.

Viewing 15 replies - 1 through 15 (of 44 total)
  • start by checking over the troubleshooting tips on the Permalinks page in the Docs section.

    After you make the change, is your .htaccess file getting updated?
    Have you tried “Almost Pretty” permalinks? (see that link above)

    Chris and Oakley,

    I am having a similar problem. Note that I am a real novice at updating my WordPress site, even though I have had it for one year.

    Chris, what would you suggest I do in response to this major mistake I made yesterday? I am hesitant to take another step on my own.

    Problem: I tried to upgrade my installation of WordPress 2.5 to version 2.7 on Friday, March 27, and as of yesterday, none of the Permalinks work on my site (http://americaninlima.com ). The new admin panel is there and the front page is up and running, though. I am upgrading through Fantastico Delux.

    I confess that I did not follow the proper upgrade procedures:
    (1) I did not backup my site prior to upgrading. The most recent full backup I have is from February 9.
    (2) I did disable plugins prior to upgrading.
    (3) I did keep a record of my hacks to WordPress prior to upgrading. I restored the code to original before upgrading, and after the upgrade, I put the hacked code back in the right and left sidebars and the footer (I’m using Cutline).
    (4) I did not delete the old WordPress files on my site when I did the upgrade. I thought that I didn’t need to do that with Fantastico.
    (5) I did not delete the htaccess file.

    I am rather at a loss where to begin to set things right. Do I restore the Feb. 9 version of my site? (I’m not even sure how to do that.) Is there some simple code I can insert into the htaccess file to repair things? (I don’t know how to get into the htaccess file. I see it in the files of my directory, but when I click on it, all I get is a screen asking me to download it, and when I do, my computer cannot open the file.).

    @americaninlima – if you visit the Permalinks page and change them to Default, do your links work?

    If so, then go back and reset them to what you want and make sure .htaccess is updated.

    Chris —

    I have pretty permalinks already. Do you mean I should change them back to default?

    Second question: How do I make sure htaccess is updated? Am I opening the file and looking at text? I have never accessed or done anything with htaccess before.

    I have pretty permalinks already. Do you mean I should change them back to default?

    Yup, that’s exactly what I suggested. Make sure Default works.

    Second question: How do I make sure htaccess is updated? Am I opening the file and looking at text? I have never accessed or done anything with htaccess before.

    Ideally, you can see the date the file changed using a shell or FTP client. Hopefully that date will correspond to your experimentation with the Permalinks page.

    Okay, when I change the Permalinks to Default, they work when I click on the titles on my site. When I change the Permalinks Setting to Day and Name, the links don’t work on my site.

    And, obviously, my pages aren’t accessible by search engines.

    Does this mean my htaccess has not been updated?

    I am trying to figure out how to use a shell or FTP client in order to check for the date.

    I am on cPanel x, using File Manager v2, examining my site’s public html directory. I can click on various files (error log, index php) and folders to view properties, but when I click on .htaccess, the dialog screen says that the page cannot be found.

    What does this mean?

    Still having problems with my permalinks being broken since upgrading to 2.7. I asked my hosting company, MidPhase, to help me, but it’s been 18 hours and so far they haven’t found a solution. I don’t know how savvy they are about WordPress but I thought I’d give them a shot since my web site is basically dead in the water.

    Can anyone suggest what next step to take?

    Could you try using an FTP client to look at the .htaccess? I have no idea what your cpanel error means, but I’ve never used a cpanel in my life…

    (If using FTP is a new concept, have a look at FTP_Clients)

    Also, you should’ve spotted this from the troubleshooting stuff on the Permalinks page, but just in case…

    When you’re changing permalinks, if WP can’t edit your .htaccess file it’ll display a message at the bottom of the page telling you what needs to be manually added.

    And finally, if you switch to Default Permalinks while you’re figuring this out your site isn’t broken.

    i cant understand your problem. There might be two problems. Fisrt, I think your htaccess file is corrupted by malware, but it may be a problem with permalinks not htaccess, need to see what you get when you click on any link.

    Thanks, Chris, for keeping with me on this.

    Yes, my site works when I switch back to default permalinks from the pretty permalinks, so the site isn’t totally broken, as you say.

    When I change the permalinks on the WP admin dashboard site, it does not give me that message that I have to manually add code to the .htaccess file. So that means my .htaccess file IS writable by WordPress, right?

    Just to clarify (for xewax) what the error message is when you click on the permalink. The error page reads:

    “Easy, tiger. This is a 404 page.
    You are totally in the wrong place. Do not pass GO; do not collect $200.

    Instead, try one of the following:

    Hit the “back” button on your browser.
    Head on over to the front page.
    Try searching using the form in the sidebar.
    Click on a link in the sidebar.
    Use the navigation menu at the top of the page.
    Punt.”

    Update: MidPhase hosting claims permalink problem is bug in WordPress.

    Dear Barb,

    From what I have been able to find out, this is a common issue with the current build of WordPress. The only solution that I have found that actually works is to switch your permalinks to the default setting. You can do that from wordpress admin Settings > Permalinks. Its likely that WordPress is working on a solution for this error, so you may be able to find a solution if you watch their forums. Please let me know if you have any further questions.


    Because we are working to improve our ticket response quality, I will be closing this ticket at this time. If you wish to continue this ticket further, please reply to this email, this ticket will reopen and I would be happy to assist you.

    Best Regards
    Matt Reeder
    Technical Support Representative

    Well huh. That’s news to me.

    What style of permalinks are you trying? Have you tried others?

    Chris, I don’t know what to make of MidPhase’s message, that the permalinks disappearing is a “common issue with the current build of WordPress.” Either they are just making that up as an excuse to “close the ticket” or it really is the case.

    Opinion?

    The style of permalinks that I’ve been using for more than one year on WordPress is day/month/year/entry-name

    If I cannot get my site to run with those permalinks I will have lost most of the traffic to my website, which comes from Google searches.

    When you’re changing permalinks, if WP can’t edit your .htaccess file it’ll display a message at the bottom of the page telling you what needs to be manually added.

    Again, if I don’t see this message when I change permalinks thru WP admin, it means that my .htaccess file IS writable by WP, right? If that is the case, why, then are my pretty permalinks no longer working?

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Posts 404ing after permalink change’ is closed to new replies.