post.php strangeness (20 posts)

  1. litlnemo
    Posted 10 years ago #

    Well. I am seeing some weirdness when posting to my blog.
    For some time now, I have been getting this error immediately after submitting a post in Safari:

    Safari can’t open the page “http://slumberland.org/wp/wp-admin/post.php�.
    The error was: “bad server response� (NSURLErrorDomain:-1011)

    This looked somewhat alarming, but it never interfered with actual posting -- the posts always appeared on the blog just fine, so I never bothered to look into it further.
    Well, I just made another post, about my problems sending pings to Ping-O-Matic, etc., and I started to wonder if the two problems were connected. It's possible they began at the same time.
    So I just tried to post in Mozilla, which I usually don't use for my blog, to verify whether the error was limited to Safari or not. And guess what -- I didn't get the "bad server response" error in Mozilla -- instead, it triple-posts. Every time. I click "publish" once, I get three posts.
    So something is broken in my posting process here, but I don't know what it could be. Does anyone have any ideas what is out of whack here? I've searched the forums but not turned up anything.

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    If it's a 'bad server response' the problem lies there.
    See if it rectifies itself after a while.

  3. litlnemo
    Posted 10 years ago #

    Well, it's been going on for a few months already. :/

  4. Check your server error logs.

  5. litlnemo
    Posted 10 years ago #

    My server admin says "there's nothing at all in the error logs that appears related to this." Is there anything specific I should have him look for? I made about 10 test posts this morning; I would think something would show up. (He does, though, say "if you want to figure this out later, let me know and i'll capture the network traffic and look." So that's the next step, I guess.)
    Has anyone else run into this?

  6. Go ahead and take the "next step". That'll help narrow it down.

  7. Wow, that is a mouth full of problems. Have you tried deleting post.php and replacing it with a fresh one? I suppose that might help. It won't harm anything.

  8. litlnemo
    Posted 10 years ago #

    Hmm. Wouldn't it have been replaced already when I installed 1.2.1? That didn't fix it. But I could try.
    Update: When I tested today the error was back. The admin looked at the server and said "whaddayaknow, there's a spinning apache process." So he's restarting the server. He says that this problem -- apache processes getting stuck -- has been going on for some time (hence so many apache restarts in the last few months), so maybe that is the cause of my WP problem. However, he has been unable to figure out what triggers the problem. If anyone has any suggestions in that area I would love to hear them.
    As far as replacing the post.php, my gut tells me it won't make a difference, but like you said, it shouldn't hurt anything either, so I will try to do that.

  9. Anonymous
    Posted 10 years ago #

    Heh. We are hosting the site ourselves on our own web server. There is no other server to move to. The "server admin" is my charming spouse, Jason. :) (It's just easier to call him the "admin" when making support queries, since he's the one who does the server administration around here.) There is a lot of stuff running on the server, though, not just the blog, and not just our own personal stuff. So, yeah, it could be anything. And Jason's been trying to figure it out for ages, since well before we started trying to fix the WordPress problem.
    He just disabled mod_gzip again, so we'll see if the problem reoccurs.

  10. Heh, you made it sound so professional. I thought you were with a hosting company.

  11. litlnemo
    Posted 10 years ago #

    Nah, that's no fun!
    So far the error hasn't returned since disabling mod_gzip. I am keeping my fingers crossed.
    Incidentally this problem sounds kind of similar.

  12. Anonymous
    Posted 10 years ago #

    The problem is back, so it's probably not mod_gzip at fault.

  13. litlnemo
    Posted 10 years ago #

    Um. That was me.

  14. Anonymous
    Posted 10 years ago #

    I've been experiencing the same problem, but first noticed it with sending mail in Squirrelmail using Firefox. I'd hit "Send" and it would seem to submit but then stop, and then I'd see the email sent three times in my Sent folder. Thinking the problem might be with Firefox, I switched to Safari and eventually received the same error you mentioned (which is how I found this thread).
    I don't have mod_gzip running on my server, but since Squirrelmail uses PHP I'd assume the problem lies there.

  15. litlnemo
    Posted 10 years ago #

    I have further information.
    A couple of days ago (I think it was Nov 13) Jason disabled apc, a php caching application.
    Since then the error has not returned, and outgoing trackbacks and pings are consistently working.
    This is notable because before this, the error would always return after less than a day (not sure HOW much less). So this is a possible fix. I'll keep an eye on it and post if I find out more.
    Any comments?

  16. Anonymous
    Posted 10 years ago #

    In the squirrelmail case, I think the problem might have been due to my inbox being atypically large and causing the imap connection to overload PHP's memory bounds. I noticed this error message in my apache logs when getting the error in Safari:
    [Wed Nov 17 19:02:17 2004] [error] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 44 bytes) in /usr/local/www/squirrelmail/src/compose.php on line 775
    At first I dismissed this as being due to some tight loop that PHP was getting itself stuck in, since I couldn't imagine any legitimate reason why it would be using that much memory. But then I noticed that the problem was occurring with increasing frequency, and it finally dawned on me that it might be related to the size of my inbox (which I assume is impacting how much memory the imap functions use when reading in the message headers).
    I cleared out some messages -- and the problem went away.
    In thinking about this more, I suspect we may not be experiencing exactly the same problem. The identical Safari error message and the fact that we were both seeing triple-postings (in my case email, in your case WP posts) made me think the problems were related, but it could just be PHP crashing in both cases for completely different reasons, producing identical results in our browsers. I suspect that Firefox/Mozilla will try three times if it gets an abnormal connection close from the server, before it gives up, and that's why we're seeing the triple posts.
    -Bill Clark

  17. litlnemo
    Posted 10 years ago #

    Well, even if the causes of the php issues are different, it's the same problem in a broad sense. So hopefully this thread will help someone.
    Status update: apc is still disabled and the error has NOT returned. Hmm. ;)
    Has anyone else been able to duplicate this specifically? Bill, do you have apc running?

  18. Anonymous
    Posted 10 years ago #

    Status update: apc is still disabled and the error has NOT returned as of Dec 1. So looks like we found our culprit!

  19. litlnemo
    Posted 10 years ago #

    Argh. That's me above.

  20. grunertch
    Posted 9 years ago #

    I am using WP 1.5.2 now and I have the same problem with the post.php, too. Is there any other solution as switching off the apc?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.