Support » Fixing WordPress » post.php & wp-comments-post.php save/open problem

  • Anytime I try and post, firefox asks me to save or open post.php. The same thing happens when users try and comment. They’re asked to save wp-comments-post.php in ff or can’t get the page in IE.

    I suspect this is a hosting problem with php? Everything seemed to work perfectly prior to a possible server restart/crash whereby my database became corrupted. I restored it from a backup to allow any access to my site.

    I’ve tried upgrading from 1.5.3 to 2.0.3 and the same problems exist. I’ve tried removing and deactivating all plugins and removing pingomatic from ping list.

    I just tried installing a clean Wp 2.0.3 on my host and it all went smoothly until I tried to access my dashboard. Then I got a blank plage. I checked with my other blog and the same thing happens. Same posting and comment problem too.

    Oooh, I just noticed my host is now running PHP 4.4.2! Previously it was 4.3.9 I think.

    Anyone know what the problem might be so I can get my host to fix it?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Not sure if I may be suffering the same problem. Have only just installed wordpress for the first time, using default everthing. Don’t have enough Knowledge yet to change anything anyway. Get the blank comments-post.php syndrome. Everything else seems fine. Seems my host is running PHP 4.4.2 as well. Is this a pattern? I would say there is definetly a bug of some sort as all of my installation is default.

    I had this problem, and checking the error logs noticed PHP was running out of memory and was killing the process. The log message was “PHP Fatal error: Allowed memory size of 8388608 bytes exhausted”

    I guess when the process died, it was before it sent all of the data and the browser didn’t know what to do with the file. If you search the forum for those error messages, you’ll get some suggestions on how to raise the memory PHP allocates per process, or the suggestion to prune back some plugins.

    What error logs do I need to check for this? It’s happening across several blogs on the server.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘post.php & wp-comments-post.php save/open problem’ is closed to new replies.