WordPress.org

Support

Support » How-To and Troubleshooting » Postname permalinks cause Page Not Found after auto update to 3.8.1

Postname permalinks cause Page Not Found after auto update to 3.8.1

  • wordsword
    Member

    @wordsword

    After the auto update to 3.8.1, when I publish a new post and click on View Post or Preview (or manually typing url), it shows me a Page Not Found error.

    My permalink settings is set to “Post name”. The problem does not exist if I change the setting to “Default” or any of the other choices like “Numeric”. But I need my permalinks to be based on post names. Other than the update to 3.8.1, no other changes were made to my site before this Page Not Found error starting happening.

    Here are the things that I have tried without success:
    1) I reinstalled 3.8.1 from the dashboard.
    2) I changed themes including one time to Twenty Fourteen.
    2) I disabled all plugins.
    3) I renamed the plugins folder (to test if a deactivated plugin may be the culprit).
    4) I checked the .htaccess file and made sure it includes this code:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    5) I changed the permission of .htaccess to 444, 644, and just about all the combinations available.
    6) I tried viewing the post when logged in vs. not logged in.

    Is there anything else I can try?

    Has anyone found a solution to this problem?

Viewing 15 replies - 1 through 15 (of 42 total)
  • Same issues, same lack of results here. :-\

    Current rewrite for custom post type:
    'rewrite' => array( 'slug' => 'products/%product-categories%' ),

    The custom %product-categories% seems to be breaking it, however only since 3.8.1.
    Ideas?

    Update:
    It’s not actually that breaking it. It’s the fact it’s more than one level deep…

    UPDATE:

    This is now working. As of version 3.1 ‘hierarchical’ was added. Seem to do the trick… not totally understanding it yet though.

    'rewrite' => array( 'slug' => 'products', 'with_front' => true, 'hierarchical' => true ),

    karenleap
    Member

    @karenleap

    I have the same issue with my site after upgrade (morphbody.com)

    I’m a bit new to WordPress – where should I put the above code?

    'rewrite' => array( 'slug' => 'products', 'with_front' => true, 'hierarchical' => true ),

    I had set up custom post types in the function.php file. If you haven’t set up any custom post types than this probably isn’t the fix you area looking for.

    I don’t see any broken links in your site though either…

    karenleap
    Member

    @karenleap

    The problem is the blog article page (not the blog page); so that clicking on the title of the post or clicking the “more” link on the front page goes to a 404. The problem is solved by changing the permalinks to default, but that breaks all of the image and button links, and is inelegant besides 🙂
    But thank you for your answer. I have been searching for a couple of days, and although many people have this problem, there doesn’t seem to be one solution that works for my site.

    Has it just been since an update or has it never worked?

    Perhaps conflicting redirect code in the .htaccess file?

    Tried disabling all plugins?

    karenleap
    Member

    @karenleap

    Just after the latest update I believe.

    I don’t know much about coding, but this is the .htaccess file that was recommended:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Also disabling plugins did not solve the problem, nor did switching themes (to 2012, and then 2013).

    Brian Jackson
    Participant

    @brianleejackson

    I have same issue here… tried disabling all plugins, switching themes… I ended up having to revert back to 3.8 for now until someone can figure this out.

    My .htaccess file is the same as above.

    See this similar thread earlier… http://wordpress.org/support/topic/cant-edit-page-after-auto-update-to-381?replies=8

    D
    Member

    @daryljimenea

    Same thing happened to me on my site after wp update to 3.8.1

    I just rebuild the links by going to permalinks in wp admin and click save, it’ll rebuild all the links.

    karenleap
    Member

    @karenleap

    Yeah, that didn’t work for me any of the approximately 125 times I’ve tried it over the last couple of days 🙂

    brianleejackson, did reverting back to 3.8 fix it? Is it still wortikng for you? I really don’t want to do that, but if that’s the only fix on offer, I’ll go ahead.

    That will really suck if it’s been a 3.8.1 bug that really has no fix…
    I don’t know how mine works – but it does. That was in the custom post types though. Other pages are fine.

    I
    Member

    @iahmed-1

    This is not a bug with WordPress 3.8.1.

    @karenleap long shot but if you have access to phpmyadmin or know how to execute an SQL statement, try the following:

    UPDATE wp_options SET option_value = ” WHERE option_name = ‘rewrite_rules’;
    UPDATE wp_options SET option_value = ” WHERE option_name = ‘_transient_rewrite_rules’;

    If this doesn’t work then rest assured the most likely suspect is a plugin. Disable all your plugins (really disable all your plugins first), execute the above SQL statements, then re-enable each plugin one by one and checking your links each time.

    Brian Jackson
    Participant

    @brianleejackson

    Well I got mine fixed… mine turned out to be a security problem on a few of the folders (the group was set incorrectly). Not sure how this happened. Anyone having this issue and having tried all the normal troubleshooting steps, you might want to reach out to your host and have them check your permissions.

    karenleap
    Member

    @karenleap

    i.ahmed: thanks for the hint. I do have access to phpmyadmin, but I have no idea how to execute an SQL statement. If you are able to, could you give me a bit more direction, for once I’m in phpMyAdmin – where exactly I should insert this script?

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Postname permalinks cause Page Not Found after auto update to 3.8.1’ is closed to new replies.