Support » Plugin: Plugin Organizer » postMetaBox error

  • Resolved Studio Pence

    (@bpence)


    Hi, after udpdating to 9.0.3 I’m seeing a PHP warning at the meta box in the page/post editor:

    Warning: in_array() expects parameter 2 to be array, boolean given in /…/…/…/…/…/wp-content/plugins/plugin-organizer/tpl/postMetaBox.php on line 28

    With debug set to true (wp-config) I’m also seeing this:

    SELECT post_id FROM tablename_po_plugins WHERE permalink = ‘../../page-name/’ and post_id != 479 AND secure = 0 status != ‘trash’ GROUP BY post_id

    Great plugin by the way!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am also seeing the same message consistently. Although I did not see any adverse impact on the functionality.

    I agree, great plugin! I use it to optimize my pages to not load unnecessary plugins.

    I too see this error. Of course, the post_id changes on each post/page the error displays on.

    It does not seem to affect functionality on the front-end but was just a little disconcerting.

    Thanks.

    Plugin Author Jeff Sterup

    (@foomagoo)

    This is because I didn’t set the list of stored post types to an empty array on activation and you haven’t used the custom post type page. I will have the activation function set it to an empty array if it doesn’t exist in the next version.

    Plugin Author Jeff Sterup

    (@foomagoo)

    This should be fixed in version 9.0.4.

    Thread Starter Studio Pence

    (@bpence)

    Thanks for the update!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘postMetaBox error’ is closed to new replies.