Support » Plugin: Post SMTP Mailer/Email Log » “Postman: wp_mail has been declared by another plugin”

  • Got this message on a client site this week. Still appears even when all plugins are disabled and theme is switched to Twenty Twenty One.

    Diag:

    OS: Linux s19.wpxhosting.com 3.10.0-1062.1.2.el7.x86_64 #1 SMP Mon Sep 30 14:19:46 UTC 2019 x86_64
    PHP: Linux 7.4.14 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=No, zlib_encode=Yes
    WordPress: 5.6 en_US UTF-8
    WordPress Theme: Salient
    WordPress Plugins: Business Hours Indicator, Classic Editor, Disable Admin Notices Individually, Enable Media Replace, Google Pagespeed Insights, GPLVault Update Manager, Gravity Forms Zero Spam, Gravity Forms, Imagify, Salient WPBakery Page Builder, Loco Translate, MainWP Child, My Custom Functions, Popup Builder, Postman SMTP, Really Simple SSL, Salient Core, Salient Nectar Slider, Salient Shortcodes, Transposh Translation Filter, UpdraftPlus – Backup/Restore, White Label CMS, WooCommerce Cart Add-Ons, WooCommerce Checkout Field Editor, WooCommerce Conditional Shipping and Payments, WooCommerce Email Customizer, WooCommerce Stripe Gateway, WooCommerce Google Analytics Pro, WooCommerce Product Details Customiser, Woocommerce Products Per Page, WooCommerce Sequential Order Numbers Pro, WooCommerce Local Pickup Plus, WooCommerce TM Extra Product Options, WooCommerce URL Coupons, WooCommerce, Yoast SEO: Local, Yoast SEO, WordPress Updates Log, WP Rocket, YITH WooCommerce Customize My Account Page
    WordPress wp_mail Owner: /home/cocomifk/domains/thesandwichspotcafe.com/public_html/wp-includes/pluggable.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, transposh_mail->transposh_mail_filter
    WordPress phpmailer_init Action(s): WC_Email_New_Order->handle_multipart, WC_Email_Cancelled_Order->handle_multipart, WC_Email_Failed_Order->handle_multipart, WC_Email_Customer_On_Hold_Order->handle_multipart, WC_Email_Customer_Processing_Order->handle_multipart, WC_Email_Customer_Completed_Order->handle_multipart, WC_Email_Customer_Refunded_Order->handle_multipart, WC_Email_Customer_Invoice->handle_multipart, WC_Email_Customer_Note->handle_multipart, WC_Email_Customer_Reset_Password->handle_multipart, WC_Email_Customer_New_Account->handle_multipart, WC_Email_Transporting_Order->handle_multipart, WC_Email_ReadyForPickup_Order->handle_multipart, YITH_WCMAP_Verify_Account->handle_multipart, WC_Stripe_Email_Failed_Renewal_Authentication->handle_multipart, WC_Stripe_Email_Failed_Preorder_Authentication->handle_multipart, WC_Stripe_Email_Failed_Authentication_Retry->handle_multipart
    Postman: 1.7.2
    Postman Sender Domain (Envelope|Message): thesandwichspotcafe.com | thesandwichspotcafe.com
    Postman Prevent Message Sender Override (Email|Name): Yes | Yes
    Postman Active Transport: SMTP (smtps:plain://s19.wpxhosting.com:465)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 5603 | 68

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Tim

    (@tneville)

    Hi @co50,

    Sorry, I can’t see an error message? Can you confirm the error you’re getting?
    Thanks for the diagnostics.

    I have a few sites running Post SMTP with Salient – so we can safely rule out the theme straight away.

    Kind Regards,
    Tim

    Plugin Support Tim

    (@tneville)

    Hi @co50,

    Sorry – I have just realised the error is in the topic title! Okay, that’s weird.

    You say this happens when all plugins are disabled? Do you have any custom code, such as in functions.php? Have you tried a clean install of Post SMTP?

    Kind Regards,
    Tim

    Thread Starter Company 50

    (@co50)

    This was fixed after updating Real Simple SSL plugin – despite the error still occurring after I disabled every plugin. Super weird.

    Plugin Support Tim

    (@tneville)

    Thanks for feeding back @co50. Glad it was an easy fix.

    Kind Regards,
    Tim

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.