Support » Plugin: Post SMTP Mailer/Email Log » Postman: wp_mail has been declared by another plugin or theme

  • Resolved krazydave

    (@krazydave)


    Just installed this on an up-to-date site and this error pops up.

    Postman: wp_mail has been declared by another plugin or theme, so you won’t be able to use Postman until the conflict is resolved.
    More info that may help – /home/xxxxxxx/public_html/wp-includes/pluggable.php:173

    I’ve searched and found that it could be a plugin conflict, however, the error remains even if all plugins are deactivated except for Post SMTP.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author yehudah

    (@yehudah)

    Please paste the diagnostic test output here

    HostName: txpro2.fcomet.com
    OS: Linux txpro2.fcomet.com 2.6.32-896.16.1.lve1.4.53.el6.x86_64 #1 SMP Sun Feb 18 08:20:42 EST 2018 x86_64
    PHP: Linux 7.0.30 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes, zlib_encode=Yes
    WordPress: 4.9.8 en_US UTF-8
    WordPress Theme: Beaver Builder Child Theme
    WordPress Plugins: ManageWP – Worker, Content Aware Sidebars, Gravity Forms, Admin Columns Pro – Pods, Admin Columns Pro, Admin Menu Editor Pro, API KEY for Google Maps, Autoptimize, Beaver Builder Plugin (Agency Version), Beaver Themer, Ultimate Addons for Beaver Builder, Better Font Awesome, Better Search Replace, Better Notifications for WordPress, CB Custom Beaver Builder Modules, Code Snippets, Display Posts Shortcode, Download Monitor, Duplicate Post, Easy Table of Contents, Easy Theme and Plugin Upgrades, FacetWP – Beaver Builder, FacetWP, Google Authenticator, Gravity Forms Signature Add-On, Imagify, Max Mega Menu – Pro Addon, Max Mega Menu, Nav Menu Item Duplicator, Smart Slider 3 Pro, Pods – Custom Content Types and Fields, Post SMTP, Really Simple SSL pro, Really Simple SSL, Redirection, Simple Page Ordering, Sucuri Security – Auditing, Malware Scanner and Hardening, Tiled Galleries Carousel Without Jetpack, TinyMCE Advanced, Widget Options, WP Fastest Cache, Wp Google Map Short Code, WP Help, WP Theme Optimizer
    WordPress wp_mail Owner: /home/kernpubl/public_html/wp-includes/pluggable.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email
    Postman: 1.9.4
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: Default (smtp:none:none://localhost:25)
    Postman Active Transport Status (Ready|Connected): No | Yes
    Postman Deliveries (Success|Fail): 9 | 0

    Plugin Author yehudah

    (@yehudah)

    Sorry, can’t point to something in your settings.

    if you disabled all plugins try to switch to WordPress default theme.

    Switching to the default theme made the error go away.
    I’m not sure what it’s conflicting with on the theme that the site is using though.
    I use the same theme on a bunch of sites and none have encountered that error yet.

    Actually, now that I’ve done some more testing, the error does actually remain even with the default theme.

    Is it possible that the plugin is reporting a false-positive?

    Plugin Author yehudah

    (@yehudah)

    Intresting…
    Can you contact me:
    https://postmansmtp.com/contact

    So, it seems I was getting some inconsistent error reporting on the site.
    When I had all of the plugins disabled, I still saw the error, but it seems that when I was activating the default theme, it refreshed and the error went away.

    Confusing to say the least!

    However, I have been able to pin it down with certainty to the “Nav Menu Item Duplicator” plugin. Fortunately, the plugin is only used during dev and I’m able to remove it at this point.

    Plugin Author yehudah

    (@yehudah)

    I can confirm that this plugin was the problem.

    I have notified the developer and hope it will be fixed:
    https://wordpress.org/support/topic/wrong-coding-practice/

    Thanks for taking over the development and support on this plugin. I certainly appreciate all of the time you’ve put into this!

    denniswimer

    (@denniswimer)

    I have been following this thread, because I have the same issues. However, I have seen a solution. The issue has been marked ‘Resolved’, but, I still don’t understand how to implement a resolution. Please repost a resolution, if possible. Thanks.

    Plugin Author yehudah

    (@yehudah)

    Do you have poptin installed?

    denniswimer

    (@denniswimer)

    No sir

    Plugin Author yehudah

    (@yehudah)

    So another plugin is causing the conflict.

    Start disable plugins one by one until the message dissaper you will know the plugin causing the issue.

    Tomer Aharon

    (@tomeraharon)

    @yehudah it can’t be Poptin. The conflict we had with Post SMTP plugin has been fixed a while ago 🙂

    Plugin Author yehudah

    (@yehudah)

    @tomeraharon

    I know, but I thought that maybe he didn’t update.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Postman: wp_mail has been declared by another plugin or theme’ is closed to new replies.