Support » Fixing WordPress » posting via e-mail — POP3 quit: connection does not exist

  • Greetings. I’m on my third version of WP (2.6.3, 2.6.5, and now 2.7), and post via e-mail still does not work. Here is the error I receive when I run wp-mail.php:

    POP3 quit: connection does not exist

    I have put in the e-mail address and password, and gotten the server and port info from GoDaddy. I have also tried this with my company’s webmail server, but to no avail. Same error.

    How can I make post-by-email work? My boss would really like it to work.

    Site: 11aliveblogs.com

    Thank you.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I’m having the exact same problem. All my e-mail settings are correct, the e-mail is working, but wp-mail.php pops up with that error. This is a major part of the site i’m working on, the owners need easy access for updates.

    Anyone have suggestions out there on how to troubleshoot this?

    I was having the same problems until I changed my email password.

    mjpratt, that is not the problem I’ve been having. All my passwords are triple-checked.

    I’m also at goDaddy (shared server). I have debugged the problem up to the point where the fsockopen in class-pop3.php times out without establishing a connection to goDaddy’s POP server.

    After three emails to the goDaddy support desk, the best answer I could get from them is:

    Unfortunately we do not allow outgoing connections through port 110 from our shared hosting environment.

    Please post a reply here if you could convince goDaddy to change their policy.

    I did another test from goDaddy’s shared hosting, this time using a POP account at my ISP i.e. not my goDaddy POP account. The posting by email to WordPress works smoothly!

    The problem therefore seems to be at the goDaddy’s POP server not receiving incoming connections from their own (and maybe other) hosts.

    I have a similar problem and i have tried three different mail servers, one on the same ISP and two on different servers, with no joy. When i call …/wp-mail.php, I get the same message after a timeout:
    POP3 quit: connection does not exist

    I am obviously getting to the POP request because it fails with the specific error.

    I also tried forcing the server, user and password in “class-pop.php”, with the same result, so it seems to be something external to WordPress, but the cause is still a mystery. It could be related to the host server and port 110 outgoing access but the ISP claims that it should work.

    It looks like i am out of tricks for email posting, at least for now. Thanks for the ideas.

    crc

    I’m getting this problem as well. I host at GoDaddy, but the account is a GMail account. Looking at the above info, it looks like it might be a GoDaddy problem? Seems odd, but it would make sense. Thought I’d give this topic a bump and see if the account being a GMail account made any difference, although I’m assuming it doesn’t.

    Anyone figure out the problem? I host at netfirms, tried to use yahoo account, my ISP, another hosting account, nothing works.

    has anyone seen this issues on dreamhost mail servers? getting the same thing and having a headache getting it working….

    anyone? thanx…

    Add me to the list of people having the same problem. I’m hosting with Godaddy and receiving the:
    ‘POP3 quit: connection does not exist’
    message when I run ../wp-mail.php

    Ditto here. I even set the port number to that recommended by my host. I guess I can check with the hosting company (LunarPages).

    Another ditto.

    Is there any way it could be done by using localhost for the mail address?
    If the mail host is on the same server?

    Ron

    Update.

    Changed the password to something simple, instead of containing underscores and stuff, and it works.

    I had this very problem and searched everywhere for an answer with no success. It may seem obvious to most but I was certain of my settings. I finally figured it out, my POP3 port is 110 and not 25.

    William

    (@wisemasterchief)

    I am utilizing Yahoo! Webhosting… after lengthy search on Yahoo! technical side, it was determined that problem was in the fact that I could not access mail processes on the mail server.. my webspace is on separate server from mail processes.

    I do not see the logic in that response. WordPress is acting like email client when it is trying to hit the pop3 server for mail. what am I missing here???? anyone else have experience with this problem while using Yahoo! Webhosting?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘posting via e-mail — POP3 quit: connection does not exist’ is closed to new replies.