Support » Plugin: WP2Social Auto Publish » Posting to Facebook doesn’t show the correct photo

  • Resolved catsfoto1se

    (@catsfoto1se)


    I’ve just begun testing this, but there are serious issues I can’t seem to get to work..
    We’ll start with the first one..

    1. When creating a post on my page, it will post it on my Facebook page, but it uses the “main page’ image instead of the posts image. (See screenshot)

    I’ve set it to share a link to my post

    When I’m posting manually on Facebook, the right one shows up: see screenshot

    Have no idea why the auto post is messing it up…

    • This topic was modified 2 years, 6 months ago by catsfoto1se. Reason: Fixed faulty link
Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter catsfoto1se

    (@catsfoto1se)

    Upon further research, I’ve found another plug-in that says the image must be a certain size and ratio 1:1

    Any information about this?
    Didn’t see any information about that in this app?

    Please set Clear facebook cache before publishing to facebook to Yes.
    When sharing link to Facebook, the Facebook crawler picks the thumbnail image from open graph tags, but sometimes Facebook’s internal heuristics may pick other images also. This is a known issue for developers, but most of the time clearing the cache fix this issue.
    If your posts do not contain any og tags then please set Enforce og tags for Facebook to Yes.
    Please make sure that your posts have a featured image or image in post content for creating og:image tag.
    From your screenshots, the images are valid as per Facebook requirements(https://www.falcon.io/insights-hub/topics/social-media-management/social-media-images-guides/).

    Thread Starter catsfoto1se

    (@catsfoto1se)

    @anjali94 I’ve finally found out the bad guy in this, only got 5 hours..

    Yoast Seo was the bad guy.
    I have no idea why, but when Yoast is activated, the post to Facebook don’t get the real featured image..

    Is there something that can be done about this?

    Please check the social media tags section in Yoast SEO.
    If you have assigned any og tags in SEO settings then please set Enforce og tags for Facebook to No in the settings of WP2Social Auto Publish.
    Multiple og:image tags results in incorrect thumbnail issues in Facebook.
    Hope this helps.
    Thank You.

    Thread Starter catsfoto1se

    (@catsfoto1se)

    @anjali94 hi again
    I’ve tested both turning off the force og in WP2social and disabling Yoast.

    …after experimenting now, with Yoast disabled, I found that some images don’t work regardless of Yoast.

    If you visit facebook.com/Rainbowpets.org you will see my last 2 test posts, both the same except different images, one is showing, the other not..

    Is your plug-in someway handling the photos or is it something that WordPress does, maybe that part don’t work ?

    Edit: Maybe to big/small photo? The feather is original 560kb(I think) and the sunset is about 4mb.
    But if there where restrictions like that, wouldn’t WP2social make sure of creating a viable size?

    • This reply was modified 2 years, 5 months ago by catsfoto1se. Reason: Added question

    Did you disabled the Yoast SEO social meta tags?
    We were unable to find any og:tags in your post’s source.
    As i already mentioned the thumbnail issue is a known one.
    Clearing the cache fix this most of the times.
    Earlier version of Facebook api allowed thumbnail image url in parameter but they have removed this feature(The api now supports picture parameter if domain verification is completed , but this is premium feature not included in free plugins).
    So we should set the image you want as thumbnail in the og:image field.
    And when you auto post by API, make a request to clear the url’s cache in Facebook or prefetch the url.
    If you enable og:tags in our plugin , it will set featured image as og:image(if no featured image then first image from post content,if both images are missing then it will not be able to set any og:images in the free version and this will only set when facebook parse your url ).
    Please enable meta tags by yoast seo or by our plugin (only one at a time).
    and enable the cache clearing option.

    Also the images are fine. If the image is smaller than the feather image in post testing – only WP2social online, it will appear as a small preview(unlike the last posts).
    If you are uploading image directly then it should not exceed 4mb .If uploading a png image then please try to keep the image size below 1 mb.
    You can use the Sharing Debugger(https://developers.facebook.com/tools/debug/) to see the information that is used when your website content is shared on Facebook.

    Hope this helps.
    Thank you.

    Thread Starter catsfoto1se

    (@catsfoto1se)

    Hi @anjali94 when I posted those two;

    https://rainbowpets.org/testing-only-wp2social-online-2/

    https://rainbowpets.org/testing-only-wp2social-online-3/

    I had Yoast disabled.
    I had force og on in WP2social.

    Nr 2 is of a 4mb photo, and it’s not shown on Facebook
    Nr 3 is a 560k photo of a feather.

    If you look at https://Facebook.com/Rainbowpets.org only photo 3 is visible, the other, nr 2 looks like it’s some kind of error message being displayed, it’s not the sunset as the photo on my site is.

    Now, if Yoast is disabled, and only WP2social is operational, why isn’t there any og information placed by WP2social?

    Edit: thx for the link to debug
    Checking with the debug, it clearly displayed image 2, can you see the correct image on Facebook? (Nr 2)

    • This reply was modified 2 years, 5 months ago by catsfoto1se. Reason: Updated

    The shared links of your WordPress posts are redirecting to 404 error( The page you were looking for couldn’t be found).
    The og:tags added by WP2Social Auto Publish when Facebook access the site for parsing/when the facebook crawler access your site , so it will appear at og:debugger when you scrape the url for debugging,not in the source code.
    You can enable og:tags in Yoast SEO or in WP2Social Auto Publish. But make sure that you set Clear facebook cache before publishing to facebook to Yes.

    Thank You.

    Thread Starter catsfoto1se

    (@catsfoto1se)

    Hi @anjali94
    Thx for still trying to help me.
    The 404 you struck was because I deleted everything to make a clean restart of everything.

    I was testing last night (my time cet+1), and added the clean cache, but as it uses more api calls, I could only do 3 tests before it shut me down, and I couldn’t wait an whole hour to keep testing.

    But it was behaving strangely yesterday, but as I wrote, the 10api/hour died quick when using clean cache.

    I’m going to mark this as solved, and I will do some more testing, slowly with 10api/hour.

    Thx for your time and support.

    You can create an app for testing(https://developers.facebook.com/apps) and set it to development mode.
    Change the Application Selection in WP2Social Auto Publish to Own App and authorize it with your own app.
    You can authorize and publish using the app in development mode, but the post will be visible to the Facebook page admin only. And after your testing, change the Application Selection back to SMAPsolution.com’s App and reauthorize.
    Thank you.

    Thread Starter catsfoto1se

    (@catsfoto1se)

    Thx @anjali94, I didn’t know that, now it will be easier ☺

    Thread Starter catsfoto1se

    (@catsfoto1se)

    @anjali94 surprise! It’s me again!

    I’ve done a lot of testing and testing and have come to this conclusion:

    If the post is published and are shown on my site on a post-template page (the one that shows post) that DOESN’T have the function to display the featured image..

    (I have no idea why something like that exist, but it does)
    Then will Facebook take the first, best image it can find on that page as featured image.

    If that’s facebook fault or yours, I have no idea.
    It Yoast is handling the og, they will mess it up more..

    If the post(at front end) not displaying the featured image in your site,then you should check your theme settings.
    If you can set og:image by Yoast then disable the settings for og:image in WP2Social Auto Publish, in both the cases enable facebook cache clearing option.
    Then cross check the post url at Sharing debugger(https://developers.facebook.com/tools/debug/).
    And check if it generate any warning/errors for your post url meta tags.
    If you set featured image then WP2Social Auto Publish will pick the featured image for posting, you can cross check this by trying the posting method upload image to timeline album. It will upload your featured image with the message format.
    The incorrect thumbnail issue with Facebook when sharing link is a known one.
    But adding thumbnail parameter requires domain verification and this is only supported in premium version of WP2Social Auto Publish.
    Hope this helps.
    Thank You.

    Thread Starter catsfoto1se

    (@catsfoto1se)

    Thx a lot @anjali94 for the help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Posting to Facebook doesn’t show the correct photo’ is closed to new replies.