WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Posting or editing a post redirects me to homepage

[Resolved] Posting or editing a post redirects me to homepage

  • Luke
    Member

    @maciakl

    I’m having major issues with my WordPress installation which started today. Here is what happens:

    1. I go to Write to create a new post
    2. I type up a post
    3. I hit Save, Publish or Save and Continue Editing
    4. I get redirected to my homepage
    5. No changes are saved

    The same thing happens when I try to edit an existing blog post or draft. It also occurs when I try to edit my theme via the web interface or try to add/edit WordPress users.

    Editing and submitting comments works normally however.

    My issue was curiously similar to the one described here:

    http://wordpress.org/support/topic/178990

    I tried following the mod_security tip listed there but it did not help. I tried disabling mod_security via the Panel but that didn’t help either.

    I also tried replacing my post.php with a fresh copy I downloaded from wordpress.org thinking that maybe it is somehow corrupted. That changed nothing.

    I tried disabling wp-supecache and wp-spamfree and that did not help either.

    I deleted the chache – no ball.

    I explicitly excluded post.php from wp-cache hoping that has something to do with it but it did not help.

    I checked and re-checked my .htaccess files many times and they seem fine. I tried commenting out the code added by WP-Cache but it didn’t help.

    I upgraded my php from version 4.x to 5.x via the Panel hoping that would do something. No result.

    I tried 4 different browsers (firefox, IE8, chrome and opera) on two different computers. All behave exactly the same – redirect me to the home page.

    This problem started today. I haven’t made any changes to the blog other than regular posting. I was able to post normally early morning (3am EST) but when I logged in and tried posting at 4pm today this issue started.

    I looked through my WordPress directory but no files seem to have changed recently. I looked through the database and I didn’t see anything out of the usual. I am at my wits end here. I have no clue what is going on.

    I contacted my host to see if they can figure out what is happening here but they haven’t responded back to me yet.

    Has anyone ever had a similar issue?

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Posting or editing a post redirects me to homepage’ is closed to new replies.