WordPress.org

Support

Support » How-To and Troubleshooting » Posting new Post leads to blank php screen

Posting new Post leads to blank php screen

  • When I post a new post. I just get a blank page.

    The URL is:
    /news/wp-admin/post.php

    I tried upgrading the wordpress installation to 2.3.2.
    I have tried deactivating all plugins and changed theme.
    But the problem occurs as well.

Viewing 15 replies - 1 through 15 (of 46 total)
  • the error log says there is a missing favicon and missing .html file I can’t think of any reason for this.

    This just happened to me, too, only more extreme. My entire site is blank. http://www.williamrubel.com/index.php generates a blank screen.

    I saved a post and the screen went blank. I have two installations of wordpress. One in the root directory — a static site — and one in a wordpress directly — a blog. A direct call to the blog …wordpress/index.php also produces a blank screen.

    I am getting cache memory full messages when I check the log file.

    Needless to say — help!

    Help! I’m having the same problem. Just started out of the blue. Have taken all the same steps as richardcycling (see above message) but all to no avail.

    Anyone else having similar problems or ideas what to do?

    thanks

    I have the same exact problem.

    /wp-admin/post.php loads a blank white page and the posts I try to create never appear.

    Nothing gets posted to me error_log and this is what i see in my acccess_log

    xx.xx.xx.xx – – [06/Mar/2008:14:57:36 -0800] “POST /wp-admin/post.php HTTP/1.1” 200 353 “-” “Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12”

    Im having the same problem on a client’s installation. Suddenly and inadvertently, we are getting a blank screen when saving or publishing a new post.

    I have deactivated all of the plugins, even tried pulling them completely out of the plugin folder. I swapped templates. Nothing seems to be working.

    What’s weird is that it worked until recently, then, without any new plugins or changes to the site, this problem started.

    I have found quite a few posts about this problem elsewhere online, but most of them seem to have been resolved by removing plugins. That really doesn’t seem to be the problem here.

    So, if anyone has any thoughts Im sure we would all appreciate them. If I find a solution, ill be sure to post.

    Thanks all!

    Hmmm… just upgraded from 2.0 to 2.5, really expecting that to take care of it. The new install hasn’t been touched by a plugin… still having the same problem.

    I am having the same trouble – out of the blue two weeks ago. At that time I had made no upgrades since 2.0 but I was able to restore my database from a 2 day-old backup and go from there (that fixed the trouble). So I went ahead and upgraded to the newest version.

    No problems again until today. Tried to post, blank screen, nothing would save, could not move forward. Restored database to a few-days-old version. That fixed the problem (again) – I posted two posts with no trouble (replacing those lost in the restore), then went to post the third and it did the same thing.

    I restored again and, out of curiousity, tried to post the last post first. It went * blank screen * on me. I restored one more time, posted the other two posts again with no trouble. I am beginning to think the problem was in the HTML of the last post, so I post it after converting to plain text in notepad – stripped ALL HTML off. Posted the plain text. It blanks out.

    When the screen freezes I can look in the SQL and see the post I am trying to post, but in the contents area there is simply a weird character sort of like an ‘A’ with squiggles on top. NOT the text I put there. The title is correct, but none of it shows in the blog.

    Restored one more time, I can post as many test posts as I want as long as I do not post the one which causes the freeze… So the problem is somewhere in the content of this post, from what I can tell.

    Woudl love to hear if anyone has ever figured this one out…

    Oh, and during one of the recovery attempts I removed the entire plugins folder and replaced it with a freshly downloaded version. No help there. The only fix I have found is to roll-back my database.

    Ok, following up – I checked on words which might be an issue and changed my htaccess file as was referenced in several posts, to no avail… still trying…

    Ok, maybe it is the length of that post, though am sure I have posted longer ones before…

    this time it errored out – blank screen – and I used the back button to go back to my previously *saved* and only slightly shorter draft, took out a paragraph… it then worked. So I am off to figure out how to override the post length… LOL

    I was able to put a certain amount of text into the post before it crashes… One more word and it pushes it over into the ‘white screen of death’ so maybe it is not a ‘certain word’ issue as I thought.

    I have found I can recover from the white screen **the first time it happens** IF I have put a SMALL amount of text into the post and saved the draft – then paste the rest, then publish. If it gives the white screen I can use the back button to get back to where I last was, but ONLY if I have a little bit of text there in a draft to revert to. Oh, and I found I can check the categories, set the time for posting, etc… Whenever (in the draft or the final) – that does not matter.

    Still trying to find the post length override – no other fixes have worked…

    sorry, this was meant to be a test post.

    Thanks for the continuing updates, redheads. I have been suspecting that it must have something to do with the database as well, since that’s the only thing that I haven’t changed or removed.

    Im getting back to this this morning, so your testing with post length and hidden characters is really helpful. Thanks for posting about it.

    Ill be back with anything that I find.

    Brad

    The thing is, I get the white screen every single time, no matter what I have in the post, or how long it is.

    Unfortunately, I don’t have a backup of the db from before this occurred. At the moment I am building a duplicate of the db so I can pull all of the posts since the problem began, and mess with things to see if I can figure out where this problem is coming from.

    Hoping this isn’t just another wrong path…

    Brad

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Posting new Post leads to blank php screen’ is closed to new replies.
Skip to toolbar