Support » Fixing WordPress » Posting and Editing taking up huge CPU

  • Resolved musicmasteria


    Hello and Thank You for looking at this.
    I’ll get right to the details…

    Recently, posting and editing has been taking up a very large portion of my shared host’s cpu.
    I have seen it go from ~4 CPU (of 8) to 100 CPU but that’s probably a calculation error. Every post makes the CPU spike up about 2 CPU (which returns to normal a few seconds after).

    When editing or posting, frequently now, when you press save/publish it will take a long time to think then go to an error message. The error message is:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ Server at Port 80

    Durring this “thinking” time, the whole site slows down as if it were down but it comes back after it is done “thinking” and you see the error message on the post.php page.

    To try and counteract this I have gone through the MYSQL database, cleared out everything that doesn’t need to be there and optimized all the tables (particularly wp_posts).

    After that I tested it, nope, still not working right.

    Then I went a bit farther by deleting all the ‘revision’ posts (i had previously disabled revisions but had never deleted the old revisions that were still there)

    This took my wp_posts table from ~8,000 entries to only about 3,000 entries. Ya, wow.

    Then, another test…
    NOPE, still not working right.

    Well what could it be now…..

    I went through all my plugins and disabled all but these:

    * Akismet (v. 2.2.3) by Matt Mullenweg.
    * All in One SEO Pack (v. by Michael Torbert.
    * Awsom News Announcement (v. 1.5.1) by Harknell.
    *** BlazinAnime FLV Player (v. 9001) by .
    * Broken Link Checker (v. 0.4.14) by Janis Elsts.
    * Custom Query String Reloaded (v. 2.9) by Moshu.
    * Exec-PHP (v. 4.9) by Sören Weber.
    * Executable PHP widget (v. 1.1) by Otto.
    * Google XML Sitemaps (v. 3.1.2) by Arne Brachhold.
    * Latest From Each Category (v. 1.8) by Dagon Design.
    * MiniMeta Widget (v. 4.1.0) by Daniel Hüsken.
    * One Click Plugin Updater (v. 2.4.4) by Janis Elsts.
    * pageMash (v. 1.3.0) by Joel Starnes.
    * Plugins list (v. 1.0) by Davide Benini.
    * Profiler (v. 1.2.8) by Eric Schulz.
    * Register Plus (v. 3.5.1) by Skullbit.
    *** Report Broken Video (v. 9999) by Basilis Kanonidis .
    * Role Manager (v. 2.2.2) by Thomas Schneider.
    * Vote the Post (v. 1.1) by Crowd Favorite.
    * Widget Logic (v. 0.45) by Alan Trewartha.
    * Stats (v. 1.3.7) by Andy Skelton.
    * WP-PageNavi (v. 2.40) by Lester ‘GaMerZ’ Chan.
    * WP Super Cache (v. 0.9.1) by Donncha O Caoimh.

    *** = Plugins that have been customized by site staff, although they have little, if not nothing to do with posting/editing

    My theme is Mandigo v. 1.37

    My host is

    Other than that, my site looks like it runs fine. (Well, good enough I guess)
    I can’t seem to figure out what is causing the problem..

    Can anyone offer me more insight into my problems?
    I might be able to find more information if it is requested.

    Thank you,
    ~Jason (Musicmasteria)

Viewing 1 replies (of 1 total)
  • Turns out at least a major cause of it was WP Super Cache not deleting the expired files correctly so they would built up and hog all the resources.

Viewing 1 replies (of 1 total)
  • The topic ‘Posting and Editing taking up huge CPU’ is closed to new replies.