Support » How-To and Troubleshooting » Posting a Comment Leads to 404

Posting a Comment Leads to 404

  • For the past week, my blog has been redirecting to me and any guests who try to comment to a 404 error page. I don’t think I’ve made any major changes to my blog. The only thing I’ve done with my blog in terms of editing it is changing a small CSS value to the paragraph (p) tag. Styles can’t possibly affect the way comments can they?

    I was on 2.8.1 when this started happening. I did an auto-update just now and the comment issue continues to persist.

    Can someone help me with my problem?

Viewing 15 replies - 1 through 15 (of 22 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    Actually yes I have tried both. They were the first things I did. Neither helped.



    Forum Moderator

    Try renaming the plugins folder via FTP. Sometimes even “inactive” plugins can continue to cause problems. It’s definitely not your CSS changes.

    Check that the last 3 lines in the <head></head> section of header.php end with:

    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head(); ?>

    Also check that immediately before the </form> in comments.php, you have the line:
    <?php do_action('comment_form', $post->ID); ?>

    You might also want to try re-uploading a fresh copy of wp-includes and wp-comments-post.php. There’s definitely something wrong with the address that’s generated used after a comment is posted:


    I’ve tried all of those options and none of them worked. I even tried uploading the whole WordPress package again and my problem wasn’t resolved.


    I’m willing to give you access to my account if you’ll help me.


    I still haven’t resolved my issue even after uploading the whole WordPress package three times.

    I take a look at your blog if you want.
    mail to admin@bloginstallationservice.com


    Hmm… Can I really trust you?

    Also, just for the record, I’ve typed “comment-page-#comment-” into Google and found people experiencing similar problems. I now realise it’s a problem with the database which is why reuploading the whole WordPress package solves nothing.

    Well as with any other security sensitive work it all comes down to trust. I assure you my intentions are honourable and I run my business with integrity so am not about to risk it for petty things.

    I advise all my customers as well as those whome I help to set up dummy users with rights and once the work is done to delete thsoe users.

    At the end of the day it is upto you to trust or not to, am just offering to help out a fellow blogger on the merit of this great forum. Otherwise I charge for such services on my site.

    Yes, I realise all of that. I have provided you with access to my account.

    I just created a blog for a friend and was having the 404 error message after someone tried to comment. I called my hosting company, BlueHost and they were able to help me figure out it was my permalink. Originally I had entered it as /%postname%/ but after talking to the extremely helpful guy at BlueHost we changed it to /%postname% notice that we ditched the last /

    Not sure if you are using this type of permalink, but it sure fixed my problem.

    Good luck.



    i had the exact same problem and the solution from mtnbikechk (last commenter0 was exactly what helped me solve it. I depeted the one trailing slash in my permalinks and then the redirect after commenting worked again.

    I’m having this issue as well, and have performed all of the above troubleshooting suggestions, without a resolution. I have also tried activating new themes. The really strange thing is that spammers are still injecting comment spam from time-to-time, but legit registered users get a 404 when posting a comment. I’m totally stumped.

    I’ve also tried replacing my theme’s comments.php file and my root wp-comments-post.php file. I am running 2.8.5, but the problem began with 2.8.1.

    Any further suggestions will be greatly appreciated.

    Found the cause: wp-comments-post.php had the wrong permissions set. Not sure how it got that way (I didn’t manually change it), but it needs to be set to 644.

    i’m currently having the same problem.

    changing the permalink structure only changed the url of the 404 page:

    instead of

    changing the permissions to 644 did not have any effect. the same theme is working perfectly on wordpress, the problem only occurs on wordpress-mu.

    any other ideas?

    ps: i have tried using comments.php from the default theme – no change. will go through the plugins now 🙁

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Posting a Comment Leads to 404’ is closed to new replies.