Support » Plugin: Postie » Postie not fetching unless I run manually

  • Resolved juliejcdesign


    Hi, I was able to install Postie and it works well if I run the script manually but it won’t fetch automatically. The website has a lot of traffic so low-volume traffic is not the issue. I looked at my config file to see if there was a line of code that was disabling wordpress cron (define(‘DISABLE_WP_CRON’, true); but there was none. I really need the plugin to fetch the email automatically and I don’t know what to do at this point to make it work. I called my hosting provider and they told me that the port 993 and 995 were open.

    Any help appreciated.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Wayne Allen


    What does Postie show if you press the Test Config button?


    I am having exactly the same issue. Would you like me to log a new ticket otherwise I am happy to provide output from Test Config button.

    Happy to donate a few bucks if this issue sorted.



    Have enabled debug in wp-config.php. No errors other than this one at server level:

    [client ***.***.***.***] client denied by server configuration: …/wp-content/plugins/postie/get_mail.php

    Note that I have marked out IP address and also top level home folder.



    Postie Configuration Test

    Postie Version: 1.5.15
    WordPres Version: 3.5.2
    PHP Version: 5.3.26
    OS: Linux 2.6.32-379.22.1.lve1.2.17.1.el6.x86_64 #1 SMP Tue May 14 21:18:13 EEST 2013 x86_64
    Debug mode: On
    Time: 2013-07-27 08:50:02 GMT
    Error log: …/wp-content/debug.log
    Postie is in …/wp-content/plugins/postie
    Cron: On
    Alternate Cron: Off
    iconv: installed
    imap: installed
    mbstring: installed
    Clock Tests
    This shows what time it would be if you posted right now

    post date: 2013-07-27 08:50:02 / 2013-07-27 08:50:02
    GMT: 2013-07-27 08:50:02
    Current: 2013-07-27 08:50:02
    Connect to Mail Host
    Sucessful POP3 connection on port 110
    No waiting messages

    I could not solve this and had ton find another solution, so I simply decided to use the basic wordpress blog by email configuration. But because I am using a multisite network, I had to ask for the help of a programmer even to make this simple function work. I wish you good luck to solve the Postie issue.

    Plugin Author Wayne Allen


    Sounds like your server doesn’t allow http requests back to itself. A good alternative is an external cron.

    Hi Wayne,

    Thanks for getting back to me.
    Together with my hosting company we have setup an external linux cronjob. Still no luck.
    Manual posting by Postie continues to work fine.
    Do you have any further ideas?


    Plugin Author Wayne Allen


    Do you have any error messages in the logs?

    i have the same problem too. local and external wp-cron.php calls don’t work.

    i have an entry in my error.log file:

    [Thu Aug 08 14:50:00 2013] [error] [client ****] check_postie

    but nothing happens. i always have to start postie manually. perhaps it has something todo with the latest plesk update to version 11.5. after this update the connection from localhost to the hosted websites is broken. so i switched to an external cron job, which in general works (according to the log file entry.

    but it doesn’t trigger the mail fetching properly.

    i am pretty sure the reason is the broken access for localhost to vhosts. if i access my webserver from localhost, always the default plesk page is opened and the request is not redirected to the proper apache vhost.

    [08/Aug/2013:16:40:01 +0200] “GET /wp-content/plugins/postie/get_mail.php HTTP/1.0” 404 303 “-” “Cronless-Postie”

    i found this log entry in the log file for the default plesk webpage. so i know what the problem is, but i am afraid you can not help me fix it.


    Happy to report that I have managed to resolve this issue and Postie is now working properly with emails now being posted accordingly and as per set schedule.

    With a little help from my hosting company (they assisted with troubleshooting)… we found that the external cron needs to be executed utilising the php quiet command, instead of wget (which has numerous issues in shared hosting for a non-root user).

    The crontab was modified and now looks like this:

    root@host [~]# crontab -lu myaccount
    30 * * * * cd /home/myaccount/public_html/wp-content/plugins/postie; php -q get_mail.php >/dev/null 2>&1

    Hope this helps others facing the same problem.



    Plugin Author Wayne Allen


    Thanks Robert

    i fixed the problem with the vhosts access from localhost and the cron job is working again.

    the last plesk update did a real mess.

    Plugin Author Wayne Allen


    @eveslage thanks for the update.

    I’ve had similar problems. Manual running was just fine but no automatic posting. I tried the cron job suggested above but got an internal server error message. Eventually discovered that none of the .php files in the postie directory were executable. Fixed that and now ok.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Postie not fetching unless I run manually’ is closed to new replies.