WordPress.org

Support

Support » Plugins and Hacks » Postie » [Resolved] Postie broken in 3.3 _fill_user() problem

[Resolved] Postie broken in 3.3 _fill_user() problem

Viewing 13 replies - 1 through 13 (of 13 total)
  • The same here…

    I commented out this function in postie-functions.php because get_user_by() is already in later versions of wordpress. Seems to have fixed the problem since my postie tests pass.

    🙂

    /* this is included in WP 2.8+. We are using our own (unmodified) version for
       backwards compatibility */
    /*
    if (!function_exists('get_user_by')) {
      function get_user_by($field, $value) {
        global $wpdb;
    
        switch ($field) {
          case 'id':
            return get_userdata($value);
            break;
          case 'slug':
            $user_id = wp_cache_get($value, 'userslugs');
            $field = 'user_nicename';
            break;
          case 'email':
            $user_id = wp_cache_get($value, 'useremail');
            $field = 'user_email';
            break;
          case 'login':
            $value = sanitize_user( $value );
            $user_id = wp_cache_get($value, 'userlogins');
            $field = 'user_login';
            break;
          default:
            return false;
        }
    
         if ( false !== $user_id )
          return get_userdata($user_id);
    
        if ( !$user = $wpdb->get_row( $wpdb->prepare("SELECT * FROM $wpdb->users WHERE $field = %s", $value) ) )
          return false;
    
        _fill_user($user);
    
        return $user;
      }
    }
    */

    I found this bug three months ago but never really dug into the code.. I’ll check out your edit and see if that fixes the issue. Otherwise it’s time to fork!

    this appeared to have worked. until the preview button stopped working for me when composing a new post. saving a draft also results in the error:

    Warning: Cannot modify header information – headers already sent by (output started at …/wp-content/plugins/postie/postie-functions.php:1) in …/wp-includes/pluggable.php on line 866

    this is unfortunate. I rely on postie.

    I’ll be VERY appreciative of anyone that can give a fix here as I rely very heavily on Postie.

    glad to offer up donations to a good fix.

    thanks!

    okay, my bad. I was getting that error because notepad kept adding those extra characters at the beginning that I couldn’t detect. had to ssh into server and VI the php to remove them. functionality is restored. about to test a postie now.

    just tested and appears to work great. thanks for the suggestion of commenting out that function.

    Same error after updating to 3.3 – Means I cannot access dashboard or any posting menus, etc.

    Without access to the dashboard, how can I fix (or disable) postie ?

    From other forum thread …

    Simply use FTP access to delete the wp-content/plugins/postie directory and all its contents.

    (Fixes the dashboard access problem, but clearly those who want to use postie need to look at fix / reinstall for postie.)

    I used the fix provided by gizmomol, and that has worked like a charm (for which, thank you, @gizmomol).

    gizmomol’s solution works. note the /* */ around the function in the code above.

    Thanks to Gizmomol for the fix. Worked like a charm. =)

    Thanks, gizmomol. Commenting out that code works like a charm for me as well :-p

    Kudos to gizmomol for the solution… I was getting frustrated until I found this solution –thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Postie broken in 3.3 _fill_user() problem’ is closed to new replies.
Skip to toolbar