WordPress.org

Forums

Postie
[resolved] Postie autocheck stoped working? (57 posts)

  1. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Please check the cron-view. You should see something like:

    Dec 7, 2012 @ 17:23 (1354901008) Every 10 minutes check_postie_hook

  2. terrykiwi
    Member
    Posted 2 years ago #

    Yes, that's there. What does that mean?
    Actually, the hourly one is there.

  3. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    That means that at least the postie schedule is officially registered with WP cron.

    In your wp-config.php find the following line:
    define('WP_DEBUG', false);

    change it to:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('POSTIE_DEBUG', true);

    save wp-config.php and click the run postie button.

    You should now have a file wp-content\debug.log

    Please post the contents here.

  4. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Also change define('WP_DEBUG', true); back to define('WP_DEBUG', false); when done.

  5. hmoore71
    Member
    Posted 2 years ago #

    @Wayne
    A quick way to check the wp-cron and postie event handling is to activate and reactivate postie. Postie check_postie_hook action should occur right away as the event is initially scheduled.

  6. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    @hmoore71

    Good point.

  7. terrykiwi
    Member
    Posted 2 years ago #

    I used the Deactivate/Activate method:

    [08-Dec-2012 00:47:47] Postie: activiated
    [08-Dec-2012 00:47:47] Postie: Setting hourly cron schedule
    [08-Dec-2012 00:47:47] Postie: activate completed
    [08-Dec-2012 00:47:47] Postie: Setting hourly cron schedule

  8. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Now that it has been activated for a few hours do you see anything in the log file that looks like an error?

  9. terrykiwi
    Member
    Posted 2 years ago #

    Well I turned logging off as you instructed Wayne. I will turn it back on again and report findings later.

    ...and BTW the emails are still waiting to be uploaded...

  10. terrykiwi
    Member
    Posted 2 years ago #

    New development:

    I turned on debug again, then went into Postie and changed the check period to 10 minutes. When I clicked the Save button, I got this:

    Setting tenminutes cron schedule

    Warning: Cannot modify header information - headers already sent by (output started at /home/tpkiwi/public_html/blog/wp-content/plugins/postie/postie-functions.php:76) in /home/tpkiwi/public_html/blog/wp-includes/pluggable.php on line 881

    I won't touch anything else until you respond...

  11. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Go ahead and set only define('WP_DEBUG', false); leave the rest of them true. That will allow Postie to log issues.

    Is there new entries in the debug.log file?

  12. terrykiwi
    Member
    Posted 2 years ago #

    wp-config changed as directed.

    Here is content of debug.log:

    [08-Dec-2012 00:47:47] Postie: activiated
    [08-Dec-2012 00:47:47] Postie: Setting hourly cron schedule
    [08-Dec-2012 00:47:47] Postie: activate completed
    [08-Dec-2012 00:47:47] Postie: Setting hourly cron schedule
    [08-Dec-2012 22:41:59] Postie: Setting tenminutes cron schedule
    [08-Dec-2012 22:41:59] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/tpkiwi/public_html/blog/wp-content/plugins/postie/postie-functions.php:76) in /home/tpkiwi/public_html/blog/wp-includes/pluggable.php on line 881
    [08-Dec-2012 22:42:26] Postie: Setting tenminutes cron schedule
    [08-Dec-2012 22:42:26] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/tpkiwi/public_html/blog/wp-content/plugins/postie/postie-functions.php:76) in /home/tpkiwi/public_html/blog/wp-includes/pluggable.php on line 881

  13. terrykiwi
    Member
    Posted 2 years ago #

    Debug log not changed.

  14. terrykiwi
    Member
    Posted 2 years ago #

    My mentor suggests going back to 1.4.3.
    Could you please provide a link to that version?
    Thanks.

  15. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

  16. terrykiwi
    Member
    Posted 2 years ago #

    I updated to 1.4.8 through the plugins page, and I am still getting this error when I attempt to change the run schedule:

    Setting tenminutes cron schedule

    Warning: Cannot modify header information - headers already sent by (output started at /home/tpkiwi/public_html/blog/wp-content/plugins/postie/postie-functions.php:76) in /home/tpkiwi/public_html/blog/wp-includes/pluggable.php on line 881

  17. terrykiwi
    Member
    Posted 2 years ago #

    Update:
    1.4.8 did not bring in any emails.

    I deleted it and installed 1.4.3 per your link to the zip file. After installation there was an error message something about unexpected files. Then when I view the settings, I get this:

    Postie Options
    array(60) { ["add_meta"]=> string(2) "no" ["admin_username"]=> string(6) "tpkiwi" ["allow_html_in_body"]=> string(1) "1" ["allow_html_in_subject"]=> string(1) "1" ["allow_subject_in_mail"]=> string(1) "1" ["audiotemplate"]=> string(35) "{FILENAME}" ["audiotypes"]=> array(5) { [0]=> string(3) "m4a" [1]=> string(3) "mp3" [2]=> string(3) "ogg" [3]=> string(3) "wav" [4]=> string(4) "mpeg" } ["authorized_addresses"]=> array(1) { [0]=> string(16) "action@ifttt.com" } ["banned_files_list"]=> array(0) { } ["confirmation_email"]=> string(0) "" ["convertnewline"]=> string(1) "0" ["converturls"]=> string(1) "1" ["custom_image_field"]=> string(1) "0" ["default_post_category"]=> string(3) "126" ["default_post_tags"]=> array(3) { [0]=> string(7) "Amusing" [1]=> string(7) "Charity" [2]=> string(4) "News" } ["default_title"]=> string(9) "Just in: " ["delete_mail_after_processing"]=> string(1) "1" ["drop_signature"]=> string(1) "1" ["filternewlines"]=> string(1) "1" ["forward_rejected_mail"]=> string(1) "1" ["icon_set"]=> string(6) "silver" ["icon_size"]=> string(2) "32" ["auto_gallery"]=> string(1) "1" ["image_new_window"]=> bool(false) ["image_placeholder"]=> string(6) "#img%#" ["images_append"]=> string(1) "1" ["imagetemplate"]=> string(274) "
    {CAPTION}

    {CAPTION}
    " ["imagetemplates"]=> array(8) { ["simple_link"]=> string(35) "{FILENAME}" ["no_wrappers"]=> string(100) "{CAPTION}" ["wordpress_default"]=> string(274) "
    {CAPTION}

    {CAPTION}
    " ["thumbnail_left"]=> string(149) "
    {CAPTION}
    " ["thumbnail_right"]=> string(149) "
    {CAPTION}
    " ["robert_felty"]=> string(264) "
    {CAPTION}
    {CAPTION}
    " ["postie_legacy"]=> string(160) "
    {FILENAME}
    " ["custom"]=> string(0) "" } ["input_protocol"]=> string(4) "pop3" ["interval"]=> string(12) "twiceperhour" ["mail_server"]=> string(18) "mail.patiopads.com" ["mail_server_port"]=> string(3) "110" ["mail_userid"]=> string(21) "wpposts@patiopads.com" ["mail_password"]=> string(10) "WPpostmail" ["message_start"]=> string(6) ":start" ["message_end"]=> string(4) ":end" ["message_encoding"]=> string(5) "UTF-8" ["message_dequote"]=> string(1) "1" ["post_status"]=> string(5) "draft" ["prefer_text_type"]=> string(5) "plain" ["return_to_sender"]=> string(1) "0" ["role_access"]=> array(3) { ["editor"]=> string(1) "1" ["author"]=> string(1) "1" ["contributor"]=> string(1) "1" } ["selected_audiotemplate"]=> string(6) "custom" ["selected_imagetemplate"]=> string(6) "custom" ["selected_video1template"]=> string(6) "custom" ["selected_video2template"]=> string(6) "custom" ["shortcode"]=> string(1) "0" ["sig_pattern_list"]=> array(2) { [0]=> string(2) "--" [1]=> string(4) "- --" } ["smtp"]=> array(0) { } ["start_image_count_at_zero"]=> string(1) "0" ["supported_file_types"]=> array(2) { [0]=> string(5) "video" [1]=> string(11) "application" } ["turn_authorization_off"]=> string(1) "0" ["time_offset"]=> string(0) "" ["video1template"]=> string(35) "{FILENAME}" ["video1types"]=> array(8) { [0]=> string(3) "mp4" [1]=> string(5) "mpeg4" [2]=> string(3) "3gp" [3]=> string(4) "3gpp" [4]=> string(5) "3gpp2" [5]=> string(4) "3gp2" [6]=> string(3) "mov" [7]=> string(4) "mpeg" } ["video2template"]=> string(35) "{FILENAME}" ["video2types"]=> array(1) { [0]=> string(5) "x-flv" } ["video1templates"]=> array(7) { ["simple_link"]=> string(35)

  18. terrykiwi
    Member
    Posted 2 years ago #

    OK, I updated Postie to 1.4.9

    Still, whenever I click the "Save Changes" button, I get this error message:
    "Setting tenminutes cron schedule

    Warning: Cannot modify header information - headers already sent by (output started at /home/tpkiwi/public_html/blog/wp-content/plugins/postie/postie-functions.php:76) in /home/tpkiwi/public_html/blog/wp-includes/pluggable.php on line 881"

    Can I send you that file so you can fix it?

  19. terrykiwi
    Member
    Posted 2 years ago #

    OK, now I can't even use the manual post to get my emails into WP. I get this:
    "Checking for mail manually
    Starting mail fetch
    Time: 2012-12-11 16:57:50 GMT
    Revision: 636678 Last Changed Date: 2012-12-09 19:05:40 -0800 (Sun, 09 Dec 2012)
    Connecting to mail.patiopads.com:110 (pop3))
    There are 0 messages to process
    memory at start of e-mail processing:30576560
    memory at end of e-mail processing:30576464"

    There are 9 emails in there waiting for Postie. I need help ASAP please. I have staff waiting for Postie to process posts.

    What can I do?

  20. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Change define('WP_DEBUG', true); to define('WP_DEBUG', false); to remove the error message

  21. terrykiwi
    Member
    Posted 2 years ago #

    This was already set to FALSE.

    While in the file, I also changed the other two to false (they were set to true):

    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', false);
    define('POSTIE_DEBUG', false);

    This got rid of the error message, but Postie will still not run either manually or automatically.

  22. terrykiwi
    Member
    Posted 2 years ago #

    Wayne,

    I have a suggestion that will help us both. Why don't I give you admin access to the blog and you see if you can find the problem and fix it.

    This will help me for obvious reasons, but it might also be useful to you for future situations with this type of issue.

    Terry

  23. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Sounds good. If you go to http://postieplugin.com/contact/ you can send me a private message with the details.

  24. NEEG
    Member
    Posted 2 years ago #

    Has there been any progress on this issue? Its a great plugin but I appear to be having the same issue as the OP. I've followed and tried the various suggestions on the thread but the automatic process doesn't seem to work for me. WP is the latest version as is Postie...

  25. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    @NEEG
    Please contact me via http://postieplugin.com/contact/ with your site details and I will try to help you.

  26. bw76ie
    Member
    Posted 2 years ago #

    I was having the same problem, but it is now working OK.
    My site is only visited occasionally, so, as suggested in this forum, I setup a cron job (on the http://www.setcronjob.com website) to access my homepage every 30 minutes, but this did not work either.
    The helpful staff at http://www.setcronjob.com had a look at it for me and corrected the cron job to directly call the get_mail.php page on my server using the following URL (replace "MyWebsite.com" with your own):
    http://MyWebsite.com/wp-content/plugins/postie/get_mail.php
    Now it works great. There may be other ways to get it to work, but this does the job for me OK.

  27. Wayne Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the report.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Postie
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic