Support » Plugin: IMDb Connector » Poster Cache Not Working – All 0 kb

  • Resolved giovanniganzinotti

    (@giovanniganzinotti)



    This plugin works great. I have been using it for quite a while. The only problem I am experiencing is the poster feature. I am unable to use the plugin to display the movie posters. In settings I have caching enabled, the permission of the cache folder is set to 755 and the plugin does write “.jpg” files to the folder. The only problem is that all these files are 0 kb and they seem to be corrupted. If I download the files with a FTP-client I am unable to watch the .jpg files.

    Any ideas how to get the poster feature to work?

    https://wordpress.org/plugins/imdb-connector/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author thaikolja

    (@thaikolja)

    Thanks for posting your question.

    The reason for the 0kb is that the function that is fetching the string is receiving no content. That can have many reasons.

    But first off: Does this happen with every movie?

    Plugin Author thaikolja

    (@thaikolja)

    If you help me out here a bit, I’m sure we find a solution very quickly. I might redevelop the cover-saving feature to make it more compatible.

    Correct all the pictures are saved with 0kb.

    Here is my page with the movies.

    http://ganzinotti.com/movies2016/

    Normally I just add my own thumbnails, but for this year I need to add 500 additional movies, so I want to speed it up a little. The movie at the bottom is added with the poster functionality of the IMDB connector. In the source you can see it refers to the correct file.

    <img src=”http://ganzinotti.com/wp-content/plugins/imdb-connector/cache/afead3c9.jpg”>

    A .jpg file exists with exactly the same name in my plugin cache folder, but this file is 0kb. And of course the browser is unable to display the file.

    If you want any additional information to help me out, please let me know!

    I am back home, so I can provide some proof:

    My PHP Code for the Thumbnails

    The Cache Folder in FTP Program

    Plugin Author thaikolja

    (@thaikolja)

    Thanks for your cooperation with this. By getting rid of this bug, I’m sure other users will profit as well.

    You now have two choices. I’ve made some test runs, locally and remotely on my web servers, under changing circumstances, but haven’t been able to recreate this error.

    I could now play around and make adjustments of what I assume might be the problem and pass them on to you so you can implement and see if that works for you. This will take some time, of course, since it’s simple trial and error.

    However, if you bring a bit trust, you can give me an access to your site and I can – after making backups of all files and database entries, of course – fix it there. I’d need FTP and /wp-admin/ credentials for that.

    The latter would speed up things a lot because I can see the results within seconds but the choice is yours. Let me know what you think. You can also contact me via kolja.nolte@gmail.com directly if you wish.

    Oh, and by the way: You’re using a deprecated function there. get_imdb_connector_* functions have all been renamed to imdb_connector_get_*. They both work, but the latter is a bit easier to recognise if you have a lot of custom code going on there.

    I believe I have send an email with all the information you requested. GO GET THAT PROBLEM, Sir!

    Plugin Author thaikolja

    (@thaikolja)

    I just fixed the bug and explained how it happened in detail in the e-mail reply.

    In case anyone else encounters this bug, please add this code to your functions.php of your currently active theme: http://pastebin.com/sFUzrfuZ

    Amazing. Thank you for all the help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Poster Cache Not Working – All 0 kb’ is closed to new replies.