Support » Developing with WordPress » Postback with a wizard

  • Hi everyone,

    I am pretty much discouraged by my problem. I am using the latest version of WP. I have a Wizard and a Checkout wizard from : http://www.phpriot.com/articles/multi-step-wizards/5 . I have modified a little bit.

    My problem is that postback don’t refer to the page. It works well when I am not on WP (and I don’t want to use an iFrame).

    $echo ='';
    	$wizard = new CheckoutWizard();
        $action = $wizard->coalesce($_GET['action']);
        $wizard->process($action, $_POST, $_SERVER['REQUEST_METHOD'] == 'POST');
    	if ($wizard->getStepName() != NULL)
    	{
    		$echo .="<h1>phpRiot() wizard example</h1>";
    	}
    //...........
    <form method="post" name ="myNamebidon" action="'; $echo.= $_SERVER['localhost']; $echo.='&?action="'; $echo.= $wizard->resetAction; $echo.='";>
    //..............
     <input type="submit" name="previous" value="<< Previous" '; if ($wizard->isFirstStep()) { $echo.='disabled="disabled"'; } $echo.=' />
              <input type="submit" '; if($wizard->isLastStep()) { $echo.='value="Finish"';  } else {  $echo.='value="Next"';  } $echo.='>>" />

    I have both wizard classes and have no problem with those. They detect my classes and I can fill out the form. I have tried multiple action events for my form and no one seems to work. It always gets to the page, sorry we couldn’t find your page even if the URL is right.

    What is wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Postback with a wizard’ is closed to new replies.