Support » Plugin: Lingotek Translation » post_type & undefined index

  • When I open the WordPress Downloads Manager in the backend (https://wordpress.org/plugins/download-manager/), under the “Profile” tab I am seeing this error:

    Undefined index "wpdmpro" in /wp-content/plugins/lingotek-translation/admin/filters-post.php on line 102

    The Download Manager page does open with parameter “post_type=wpdmpro” (even though I don’t use the pro version).
    In order to fix this I added a few more isset checks:

    			if ($post_profile) {
    				echo $profiles[$post_profile->description]['name'] . sprintf('<a title="%s">%s</a>', __('Not set to the content default profile', 'lingotek-translation'), '*');
    			}
    			else if ($post_language && isset($content_profiles[$post_type]) && isset($content_profiles[$post_type]['sources'][$post_language->slug])) {
    				$profile = $content_profiles[$post_type]['sources'][$post_language->slug];
    				echo $profiles[$profile]['name'];
    			}
    			else if (!empty($content_profiles) && isset($content_profiles[$post_type]) && !isset($profiles[$content_profiles[$post_type]['profile']]['name']))
    			{
    				echo esc_html( __('Disabled', 'lingotek-translation') );
    			}
    			else if (!empty($content_profiles) && isset($content_profiles[$post_type])) {
    				echo $profiles[$content_profiles[$post_type]['profile']]['name'];
    			}
    			else {
    				if ($post_type == 'post') {
    					_e('Automatic', 'lingotek-translation');
    				}
    				else if ($post_type == 'page') {
    					_e('Manual', 'lingotek-translation');
    				}
    			}
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘post_type & undefined index’ is closed to new replies.