WordPress.org

Ready to get started?Download WordPress

Forums

Network Latest Posts
post_ignore= (10 posts)

  1. kjulietkxray
    Member
    Posted 2 years ago #

    The latest post's ID that I have is 204, however, I do not want the latest post on there, but the one prior. I use post_ignore=204 but it says: Sorry, I couldn't find any recent posts matching your parameters.

    How do I use post_ignore= properly? I have posts going to multiple areas of the network and I want to block some of them from showing up on network latest posts.

    http://wordpress.org/extend/plugins/network-latest-posts/

  2. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Could you please provide the full shortcode you're using in your site? The way you've set the parameter is ok, so in theory it "should work":

    [nlposts post_ignore=204]

    By the way, are you using the latest version v3.5.4?

    I'm looking forward to you answer.

    Best regards,
    José Luis.

  3. kjulietkxray
    Member
    Posted 2 years ago #

    here is the code:
    [nlposts title_only=false number_posts=1 display_type=ulist blog_id=17 thumbnail_url=center thumbnail=true excerpt_length=5 auto_excerpt=true display_content=false excerpt_length=20 thumbnail_wh=200x200 post_ignore=204]

    i have not upgraded to the most recent wp. im on 3.5

  4. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    I've noticed some parameters incorrectly used in your shortcode, the thumbnail_url can only be used in combination with thumbnail_custom and its value must be the URL address of your custom thumbnail. I think you meant to use: thumbnail_class=center, the excerpt_length was declared twice.

    The display_content=false parameter don't need to be declared as it's false by default.

    Try with this one:

    [nlposts number_posts=1
               title_only=false
               display_type=ulist
               blog_id=17
               thumbnail=true
               thumbnail_class=aligncenter
               thumbnail_wh=200x200
               auto_excerpt=true
               excerpt_length=20
               post_ignore=204
    ]

    As you choose "number_posts=1" it will display only one post from blog ID 17, in theory this new shortcode should work.

    Please, let me know if this solve the issue.

    Best regards,
    José Luis.

  5. kjulietkxray
    Member
    Posted 2 years ago #

    Thank you for your reply. Post 204 still displays with the code you supplied. Is there another way to refer to it? Is there another way to keep a certain post from displaying there? There are duplicate posts in different blogs and I'd like to block them from showing up on all except one.

  6. kjulietkxray
    Member
    Posted 2 years ago #

    Correction, I changed the display to 2 and it blocks the first one. So it effectively blocks the post from being displayed, and not from being fed into the display (in other words skipping over it). I get it now.

    Here is another question for you. How do I align everything to the left with no bullet marks? I want graphics title, and excerpt all aligned left with no bullet points. no ul/li.

  7. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    It "should" work with 1 post, I tested it myself but couldn't say why isn't working in your site.

    As for the styling question, it should already display lists without bullet points, I'm wondering if the plugin's CSS file is being included correctly. Please download this CSS file: NLP Align Left, save it to your WordPress active theme folder as nlp-alignleft.css, then add the css_style parameter to your shortcode, like this:

    [nlposts css_style=nlp-alignleft]

    That should do the trick.

    Cheers,
    José Luis.

  8. kjulietkxray
    Member
    Posted 2 years ago #

    Thanks for your help. I have set it up as you stated however, the graphic, and excerpt are bulleted as if they were in a list.

  9. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 2 years ago #

    Hello, could you please provide the link to your site? at least where you're testing the plugin? I wonder if your theme is using some sort of reset, however it's weird because the stylesheet I provided uses the !important statement that forces the style to be applied.

  10. kjulietkxray
    Member
    Posted 2 years ago #

    thanks, please email me for a link to the site as it is of a private nature. kjulietkxray@gmail.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.