Support » Plugin: Slimstat Analytics » Post view count counted incorrectly

  • Resolved computershowtopro

    (@computershowtopro)


    I’ve discovered today that the post views are not counted correctly. I’ve made a goo.gl link for one of my posts, on a 4.7.3 wp with the new beta version of slimstat installed, and there is an enormous difference between what the goo.gl analytics reports, and what slimstat reports.
    Goo.gl says there have been 122 visits to that page, and slimstat only recorded 8 people. The link was spread on social media, so the rest of the visits cannot be bots, and I’ve also got another, in-house, barebones kind of stats, which also report 120 visits.

    Is there any way to improve the precision on the post view count ?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Slimstat is quite accurate in tracking page views, so there must be some other reason why the tracker is not doing its job on your website right now. Is the tracker set to work in client or server mode? Do you have a caching plugin installed? Have you checked the Maintenance tab for possible clues? (errors)

    Best,
    Jason

    It works in client mode, because I use hypercache on the site. Other then that… on the maintenance tab, what I’ve seen is the link prefetch requests – I don’t have any rel=’prefetch’ on the site as far as I know – and one single, XSS injection attempt.
    Should I add something to my Hypercache’s exception list, in order for the pageviewes to be tracked more accurately?

    Plugin Author Jason Crouse

    (@coolmann)

    Are you filtering prefetch requests in Slimstat? (settings)

    • This reply was modified 2 years, 5 months ago by  Jason Crouse.

    The only switch that is on, on the filters page, is “Ignore prefetch requests”.
    Could that be the culprit. From what I’ve read… that one should only affect the prefetch requests, and as I’ve said… to my best knowledge, there are NO prefetch links on the site, except the dns prefetch of wordpress, for gravatar.
    I’ve added slimstat_tracking_code as a cookie to bypass in Hypercache (people having this cookie present, should not be served cached pages), which practically means everyone, so I’d might as well turn caching off.
    I’d really love this post counter to work 🙁

    Plugin Author Jason Crouse

    (@coolmann)

    Firefox and other browsers implement client-side link prefetching regardless of the LINK header tag on the page, at least in older versions:

    https://www.howtogeek.com/howto/internet/firefox/quick-tip-turn-off-prefetching-in-firefox/

    and

    How to disable Firefox prefetching from firefox

    Most people don’t deactivate this feature, and that might explain the difference among counters. Try turning that option ON in Slimstat, and see if numbers align with your other tools.

    Best,
    Jason.

    • This reply was modified 2 years, 5 months ago by  Jason Crouse.
    • This reply was modified 2 years, 5 months ago by  Jason Crouse.

    Now that was a very surprising response, from you, honestly 🙂
    First of all, whether I deactivate link prefetching or not, on my browser, has no effect on what other visitors to the site might have in their browsers;
    second, I don’t use firefox, I’m using chrome;
    and third, when there’s something wrong with your car engine, you don’t start changing tires, hoping it will fix the engine issues.
    While I really, really like(d ?) this plugin, I’m not sure this is a realistic answer on your part, but thanks for taking the time anyways.
    I’ll mark this post as resolved, but we both know it isn’t.
    I’m very surprised by how little effort plugin devs on wp are willing to put into debugging.

    Plugin Author Jason Crouse

    (@coolmann)

    I’m not sure I explained myself correctly, based on your answer here above. I was NOT implying that YOU should change your browser. I was just trying to say that Firefox has this feature enabled regardless of the prefetch TAG in your source code. You mentioned multiple times that you DO NOT have that tag on your site, and based on that observation, my point was that it doesn’t really matter, as Firefox will prefetch links regardless (and that’s why I quoted those two links in my previous message). Sorry for the miscommunication.

    Can you tell me how many of the 120 page views recorded by your other tools are generated by Firefox? Also, can you please try and deactivate this option in Slimstat as I had suggested, and see what happens?

    Look, it’s your choice to work with me to understand the cause or just walk away. I will just not accept your “little effort plugin devs on wp are willing to put into debugging”: our track record on this forum proves you wrong many many times. Your false allegations just don’t help. But again, you’re entitled to your own opinions. I’m just 1) stating the facts and 2) trying to help (free of charge).

    I am quite aware that the request is not resolved, and as you can see I’m here to help, not to hide behind a finger 😉

    Best,
    Jason

    • This reply was modified 2 years, 5 months ago by  Jason Crouse.

    Ok, you’re right.
    I’m an autistic person with Asperger’s, so I might interpret things differently then others.

    I’m not aledgeing anything, I understand your effort, and appreciate it.
    Sorry if I was too harsh, it’s just how I let my mouth speak instead of my mind sometimes 🙂

    Could lazy load be the culprit then ?

    Plugin Author Jason Crouse

    (@coolmann)

    I would investigate the prefetch option before moving on to other possible causes.

    Jason

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Post view count counted incorrectly’ is closed to new replies.