Support » Fixing WordPress » Post Via Email on WAMP Server

  • Resolved mahmoudtahan91


    Hi! I installed WordPress on my local WAMP server and I’m trying to use ‘Post Via Email’ from WordPress’ ‘Writing Settings’. I’m using a Gmail account. I tried:

    Mail Server = ssl://
    Mail Server =
    Port = 995 (Since it requires SSL)
    Username = (myusername)
    Password = (mypassword)

    Nothing seems to work. I’m not getting any errors regarding the connection. All I’m getting is “Slow down cowboy, no need to check for new mails so often!” which is not very helpful. I also tested the POP3 configuration outside of WordPress just to be sure and it worked fine. Perhaps WAMP cannot connect to POP3 without having a mail server installed? I’m lost.

    ADDITION 01 (April 28, 2013 at 00:39 UTC)

    • I checked my Gmail settings just in case POP3 was accidentally disabled. It’s enabled.
    • I sent multiple test emails to the email account I’m using in WordPress for ‘Post via E-mail’. Still nothing.
Viewing 1 replies (of 1 total)
  • Nevermind. It worked. Here’s how I did it:

    Step 1:
    In Gmail’s settings under ‘POP Download’, I checked on “Enable POP for all mail (even mail that’s already been downloaded)” even though the Status was “Status: POP is enabled”.

    Step 2:
    Set Mail Server to ssl:// Gmail requires SSL so simply writing will NOT work.

    Step 3:
    Set Port to 995. That’s usual value for SSL.

    Step 4:
    Set Login Name and Password to the e-mail address you wish to use for posting to wordpress and its password respectively.

    Step 5:
    In WAMP’s php.ini file, I enabled extension=php_openssl.dll which I’m guessing enables PHP to connect via SSL.

    Step 5 was due to an error I got when I tried to test my POP3 configuration using the WordPress plugin called ‘Postie’ which by the way doesn’t seem to work at all.

Viewing 1 replies (of 1 total)
  • The topic ‘Post Via Email on WAMP Server’ is closed to new replies.