• Hello,

    First: thank you for this amazing plugin!

    When a post is updated, the “Post updated ” webhook is sent twice.

    Has anyone encountered this problem?

    WordPress back-office send two request when he update a post :
    – POST /wp-json/wp/v2/post_type/1000127?_locale=user
    – POST /wp-admin/post.php?post=1000127&action=edit

    I presume 2 requests result 2 webhooks.

    Is there a solution to only have one webhook notification? Nothing seen in support or in documentation.

    Thank you

    Have a good day

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hey @nforgeot – Thank you a lot for your message, as well as for using our plugin.
    If WordPress or any plugin updates the post within the code multiple times, the webhook also gets sent multiple times, depending on the amount of updates.

    Luckily with our new version 3.3.0, we introduced a feature that allows you to limit webhook calls of the same nature within the same WordPress instance.
    To use it, simply head over to your added “Send Data” URL, open the settings, and make sure to check the “Fire only once per instance” setting.

    @nforgeot Did this help option help you? I have the same problem running the 3.3.0 and enabled the “Fire only once per instance” option and it’s still coming through twice. I’m wondering if it’s to do with METABOX or ACF which I’m also running but deleted these fields from the post type.

    Hmm, I think this could be Gutenburg switched back to classic and we’re all good. Would be interested if anyone else has the same experience.

    Plugin Author Ironikus

    (@ironikus)

    Hey @jasongreenlees – That’s a great question – This issue might appear due do Gutenberg. I assume they re-save the post via ajax, which is a separate WordPress instance that is always considered a separate call.
    We are already planning an implementation to address this issue.

    I have the same issue of webhook response being duplicated on post published or post updated with Guttenberg. When will this be fixed?

    Also switched back to the classic editor and works as expected.

    Yes, I also tried switching to classic editor and there is no duplication.

    Plugin Author Ironikus

    (@ironikus)

    Hey @dmwalk @jasongreenlees – What appears as an issue is just the right thing to do for our plugin as Gutenberg really creates the post first and then changes the status. This happens due to Ajax. We added so far a filter that can limit the execution of the same action to one time within the same instance, but with Gutenberg, the second requests happens via ajax, so for any kind of plugin it would appear as a separate request.

    To fix that, I could currently only thing of a secondary check using our Flows feature of the pro version (as it allows conditioning).
    We are planning to implement our Flows feature into this free version, but this requires some more time due to guidelines and other regulations.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.