POST to /wordpress/wp-admin/post.php not supported. (5 posts)

  1. johncsnider
    Posted 6 years ago #

    Everything was working fine until this morning. When I try to post a new entry on my blog (www.AmericanFreethought.com), I get this error message:

    Method Not Implemented

    POST to /wordpress/wp-admin/post.php not supported.

    Any ideas what might be causing this and how to fix it?


  2. Usually this is caused by mod_security. Ask your host to disable it or how to disable it.

    It could also just be a problem with your host, since you say it was previously working fine.

    Either way, you need to ask them about it.

  3. johncsnider
    Posted 6 years ago #

    Well, I tried a little experiment. I tried adding a new post titled "test please disregard" with only the word "test" in the body. I gave it a tag "test" and gave it a category at random. It uploaded no problem. I then deleted that test entry and tried to repost a more wordy entry, but one that was just text (i.e. no hyperlinks, weird characters, images, etc.). I got the "Method Not Implemented" error message.

    I then tried the "test please disregard" test again and no problem.


  4. bridgesolution
    Posted 6 years ago #

    on a very similar theme, i have a blog that ran successfully for 161 posts. suddenly, the posts do not appear on the domain.
    the page loads correctly, except there is no post there.
    from the dashboard i can pull up the posts, see them and edit them.
    i looked at each file i could find for "date modified" to see if there had been a hack....since i was advised the cont had "disappeared" by someone who (on another blog) had objected to it.
    i can find no evidence of something being changed.
    also, i noticed (if this helps at all) that the ico file does not load into the "url line" as it had previously.
    any and all help appreicated. i am very much a non-techy, and the most plain, "left click, right click" kind of guidance will be the most useful.
    please assume that i know >nothing< on coding.
    thank you.

  5. I got the "Method Not Implemented" error message.

    I then tried the "test please disregard" test again and no problem.


    That's a *really* good sign that mod_security is causing your problems.

    Try adding this to the top of your .htaccess file:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Might not work, since you might not have access to disable it on that level. Still, worth a try, shouldn't break anything.

    If it doesn't help, you're pretty much boned unless you can get your host to fix the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic