Support » Plugin: List category posts » Post thumbnails not showing after update!

  • Since updating to LCP 0.27 (and WP 3.5) post thumbnails on a list-category-posts page don’t show up. Shortcode for that page (http://www.jimsrootsandblues.com/):

    [catlist name=feature numberposts=1 thumbnail=yes excerpt=yes]
    [catlist name=blog numberposts=1 offset=2 thumbnail=yes excerpt=yes]
    [catlist name=john-saroyan numberposts=1 thumbnail=yes excerpt=yes]
    [catlist name=blog numberposts=1 offset=3 thumbnail=yes excerpt=yes]

    I’m using a child theme of Twenty Eleven 1.5. All worked fine before updating. Any ideas?

    http://wordpress.org/extend/plugins/list-category-posts/

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same problem in my website. 🙁

    Plugin Author Fernando Briano

    (@fernandobt)

    Was there an update on the theme? If so, check that the functions.php file in the theme includes this code add_theme_support( 'post-thumbnails' );.

    I’m using WordPress 3.5 with a customized theme and List Category Posts 0.27 on this page, and as you can see the thumbnails are displaying. I’m using this code:
    [catlist numberposts=10 excerpt_size=10 excerpt=yes thumbnail=yes thumbnail_class="alignright" class="lcp_catlist_clear"]

    Maybe test with a different theme to see if the issue is on the theme, or there’s actually a bug in the plugin which is not displaying the thumbnails.

    I tried with Twenty Ten, Twenty Eleven and Twenty Twelve. No luck.
    Twenty Eleven (parent of my child theme) says,

    // This theme uses Featured Images (also known as post thumbnails) for per-post/per-page Custom Header images
    	add_theme_support( 'post-thumbnails' );

    in its functions.php file.

    So I’m still stumped! No thumbnails. Any other ideas?

    Plugin Author Fernando Briano

    (@fernandobt)

    Check out this link, deactivate every plugin and see if there’s one that’s causing the issue or just my plugin that isn’t working.

    I assume all of the posts you are trying to list have a featured image, since you were able to see the thumbnails before upgrading to 3.5.

    I see there have been updates in the Media Manager, but can’t find anything related to thumbnails that might be not working. Let me know if you find anything that may help.

    Deactivating other plugins does not help.
    No posts used “featured images” prior to this new perplexing development.
    The new media manager may be partly to blame, because I no longer see the ability to edit thumbnails. The library used to keep thumbnails in its database, I think.
    Perhaps there’s a thumbnail plugin or bit of code I could add to functions.php?

    It has nothing to do with plugins…its something with this update. There have been thousands of complaints about thumbnails and Ive tried multiple themes with linked images on the homepage and none of them show

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Post thumbnails not showing after update!’ is closed to new replies.