Support » Plugin: Post SMTP Mailer/Email Log » Post SMTP causing problems with WooCommerce Notifications

  • WHen WooCommerce tries to send one of its notification emails, the “Reply-To:” email address is not properly formed when Post SMTP is activated, and this causes sending of the email to fail.

    What I am seeing is that the Reply-To: has the “From” name setting from WooCommerce “Email Sender Options”, but not the actual email address as specified in the WooCommerce “From” address setting. The “From” email address in the outgoing email is formed properly.

    I know that Post SMTP is responsible because if I deactivate the plug-in, the email goes out just fine.

    Here are Droplr links to what I’m seeing:

    Post SMTP Error Log:
    View of Email Top:
    Relevant WooCommerce Setting:

Viewing 9 replies - 16 through 24 (of 24 total)
  • Plugin Author yehudah


    Great, thanks for the update.

    I will add another warning to use it only as a last step.

    Switching to mailer did not work for me. It is what caused it. When I switch to the smtp it looks like emails go to spam.



    I have the same issue.
    WooCommerce does not populate the “reply-to” header correctly when using PHPmailer and all store notifications are failing.
    Switching to PostSMTP delivers as it seems but at the cost of a high spam rating. I have ticked to remove the Post SMTP X-Header now to see if that makes a difference…

    • This reply was modified 4 months ago by nadworks.


    I still am having issues with this! Very frustrating. I have tried both mailer settings and I still don’t get emails delivered. I need a fully functional store. How can I get help please? Can an admin contact me to login and look at this?

    Thank you.



    I finally gave up on this plugin and went with: WP Mail SMTP. No problems, 1st attempt. Good luck!

    I have the same error.
    The plugin has added value with the “log” function over “easy wp smtp”.
    But if the former keeps having this error, I shall have to choose the latter.

    Good luck with the debugging of your awresome plugin

    This happened to me too; changing to PostSMTP worked for me as well.

    Thanks for the fix. I read in the plugin that PHPMailer may be preferable to use for other reasons(?). Perhaps Yehudah you could inform us when/if there is an update that addresses this on this thread? That would be great! thanks. 🙂

    Plugin Author yehudah


    I want, but it’s so easy to complain without helping me too.
    I know email delivery is important but I need that one user will help debug this.

    Anyone who wants help me fix this can contact me here:


    Anyone who wants help me fix this can contact me here:

    I am waiting for a response to my last detailed email to you. Please guide!


    • This reply was modified 1 month, 3 weeks ago by KoolPal.
Viewing 9 replies - 16 through 24 (of 24 total)
  • You must be logged in to reply to this topic.