Support » Plugin: Post SMTP Mailer/Email Log » Post SMTP causing problems with WooCommerce Notifications

  • WHen WooCommerce tries to send one of its notification emails, the “Reply-To:” email address is not properly formed when Post SMTP is activated, and this causes sending of the email to fail.

    What I am seeing is that the Reply-To: has the “From” name setting from WooCommerce “Email Sender Options”, but not the actual email address as specified in the WooCommerce “From” address setting. The “From” email address in the outgoing email is formed properly.

    I know that Post SMTP is responsible because if I deactivate the plug-in, the email goes out just fine.

    Here are Droplr links to what I’m seeing:

    Post SMTP Error Log: https://d.pr/i/43W8iS
    View of Email Top: https://d.pr/i/1rgvX6
    Relevant WooCommerce Setting: https://d.pr/i/xtHgiU

Viewing 15 replies - 1 through 15 (of 26 total)
  • I can confirm I am having the same issue. Invalid “Reply-To” e-mail address error. I de-activate Post SMTP plugin and the emails go out without a bother.

    Not totally related to this issue, but can be addressed with one fix.

    Sometimes users fill in wrong email address, which causes Post SMTP to send notification about the error to site administrator, but shop manager doesn’t receive New Order email, because Reply-To email doesn’t exist. Customer won’t receive the email because the address is incorrect, but shop manager should receive it. Other SMTP plugins somehow handle this better (at least New Order email is delivered..)

    This happening to me too. I config Reply-To with my e-mail address name@mydomain.com
    After I sent e-mail to the above e-mail. I got Mail delivery failed: returning message to sender.

    This message was created automatically by mail delivery software.
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    SMTP error from remote mail server after end of data:
    550 Reply-To contains invalid characters.

    I switched to other SMTP Plugins with the same config and this problem completely gone.

    Plugin Author yehudah

    (@yehudah)

    Hi everyone,

    Sorry for the delay, I have a few personal stuff to resolve and I promise to check this until tomorrow.

    Hi,
    I can also confirm that the problem exists

    In my case, WooCommerce notifications, with the recipient is configured manually, are not delivered:
    -New order
    -Cancelled order
    -Failed order

    Other notifications like
    – Order on-hold
    – Processing order

    with the default recipient “Customer”, delivered without trouble.

    Plugin Author yehudah

    (@yehudah)

    Hi,

    If someone here is willing to troubleshoot this bug with me, please contact me here:
    https://postmansmtp.com/contact/

    select “other” in the dropdown.

    Thanks

    Repeatable error – try to resend woocommerce order notification generates error every time:

    Error Details ============= An error of type E_RECOVERABLE_ERROR was caused in line 148 of the file /var/www/html/wp-content/plugins/post-smtp/Postman/Postman-Email-Log/

    Any news on this? I have the same problem as described above.
    There is a workaround to receive Woocomerce notification mails, disable e-mail validation
    https://d.pr/free/i/EStfqR

    Then the reply-to look like this:
    https://d.pr/free/i/lxmcSC

    I hope this problem can be solved urgently.

    • This reply was modified 1 year, 4 months ago by rastelli2405.

    I had this same problem but found a solution.
    We have 2 websites that are functionally very similar. One was sending emails with no problems. The other was reporting “invalid reply-to” errors.
    By comparing these 2 sites, which are hosted on the same server, I found that the only difference was the outgoing server identification.

    Although the cPanel configuration information provided a valid outgoing server identification that would allow emails to go out when Post SMTP validation was turned off, that outgoing server was not the same as the server identified for the site that was working properly.

    After changing the outgoing server to match the site that was working OK, both websites are now sending properly formatted emails with no reply-to errors. I don’t know if this a common problem that is affecting other websites, but I would recommend re-checking the outgoing server setting to make sure it is fully valid.

    TEMP SOLUTION:

    Seem that the reply-to bug only occurs when Mailer Type = PHPMailer.
    Set Mailer Type = PostSMTP and the problem will be solved.

    Plugin Author yehudah

    (@yehudah)

    @matthieuh
    Thank you for sharing.

    Do you have multiple emails defined for reply-to?

    I have no reply-to setup inside woocommerce as you can see in screenshot (sent by email). Seem that phpmailer is taking the “From Name” instead of “From Email” of woocommerce/settings/notification/ to fill reply-to fields inside postmansmtp plugin.

    use postSMTP instead of PHPMailer is teh way to temporarely resolve this.

    Fallback account also present the same bug with PHPMailer and works with postSMTP.

    The error message i receive in my email is:

    You getting this message because an error detected while delivered your email.
    For the domain: https://deezign.com.br
    The log to paste when you open a support issue:
    Invalid “Reply-To” e-mail address “deezign”

    Can confirm still an issue. I’m having similar results with a different plugin and using the mailer type PHPMailer. It’s trying to set the reply-to field to “name <email>” but is being rejected as “name” is not a valid email.

    If I deactivate Post SMTP it sends fine with the same reply-to, but I’m having php mail() issues so tried this plugin. Haven’t tried with setting mailer type to PostSMTP yet.

    Plugin Author yehudah

    (@yehudah)

    Hello everyone,

    Please try to change to PostSMTP mailer.

    I switched to PostSMTP mailer 5 days ago and all outgoing emails since then have been sent correctly.

Viewing 15 replies - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.